none
SAP CRYSTAL REPORTS - INTERNET EXPLORER/GOOGLE CHROME RRS feed

  • Pergunta

  • Senhores, 

    estou usando o Crystal Reports e quando eu gero o mesmo pelo Google Chrome vai correto. Quando coloco como programa padrão o internet explorer fica conforme imagem abaixo. 

    Preciso saber o que está ocorrendo, pois se o usuário terá que utilizar independente do navegador. 

    Meu IE é a versão 10.


    Kelsen Nunes



    • Editado Kelsen Nunes segunda-feira, 17 de fevereiro de 2014 21:03
    segunda-feira, 17 de fevereiro de 2014 21:01

Respostas

  • Bom dia Kelsen,

    Você está com essa opção habilitada: 

    • Internet options> trusted sites> Custom level> Scroll down Active x controls and plug ins> enable Run Active x controls and plug ins

    ?

    Se não estiver habilite a mesma.

    Outra coisa, você chegou a verificar se esse erro ocorre mesmo com modo de compatibilidade?

    Você também poderia verificar se o Report aparece normalmente com outra versão do IE, basta apertar F12 para abrir o development tools e mudar o Browser Mode:

    Creio que deve funcionar corretamente no IE com Browser Mode IE9

    Se ele funcionar corretamente com algum outro browser mode você pode forçar seu report a abrir com esse modo, colocando o seguinte comando na page head's section onde você esta usando o Crystal Reports:

    <meta http-equiv="X-UA-Compatible" content="IE=9"/>
    Att,


    Giovani Cruzara – Microsoft Contingent Staff

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    Msdn Community Support

    Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    • Marcado como Resposta Kelsen Nunes terça-feira, 18 de fevereiro de 2014 12:42
    • Não Marcado como Resposta Kelsen Nunes terça-feira, 18 de fevereiro de 2014 12:49
    • Marcado como Resposta Kelsen Nunes terça-feira, 18 de fevereiro de 2014 12:49
    • Não Marcado como Resposta Kelsen Nunes terça-feira, 18 de fevereiro de 2014 12:49
    • Marcado como Resposta Kelsen Nunes terça-feira, 18 de fevereiro de 2014 12:50
    terça-feira, 18 de fevereiro de 2014 11:18

Todas as Respostas

  • Bom dia Kelsen,

    Você está com essa opção habilitada: 

    • Internet options> trusted sites> Custom level> Scroll down Active x controls and plug ins> enable Run Active x controls and plug ins

    ?

    Se não estiver habilite a mesma.

    Outra coisa, você chegou a verificar se esse erro ocorre mesmo com modo de compatibilidade?

    Você também poderia verificar se o Report aparece normalmente com outra versão do IE, basta apertar F12 para abrir o development tools e mudar o Browser Mode:

    Creio que deve funcionar corretamente no IE com Browser Mode IE9

    Se ele funcionar corretamente com algum outro browser mode você pode forçar seu report a abrir com esse modo, colocando o seguinte comando na page head's section onde você esta usando o Crystal Reports:

    <meta http-equiv="X-UA-Compatible" content="IE=9"/>
    Att,


    Giovani Cruzara – Microsoft Contingent Staff

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita.

    Msdn Community Support

    Por favor, lembre-se de “Marcar como Resposta” as respostas que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    • Marcado como Resposta Kelsen Nunes terça-feira, 18 de fevereiro de 2014 12:42
    • Não Marcado como Resposta Kelsen Nunes terça-feira, 18 de fevereiro de 2014 12:49
    • Marcado como Resposta Kelsen Nunes terça-feira, 18 de fevereiro de 2014 12:49
    • Não Marcado como Resposta Kelsen Nunes terça-feira, 18 de fevereiro de 2014 12:49
    • Marcado como Resposta Kelsen Nunes terça-feira, 18 de fevereiro de 2014 12:50
    terça-feira, 18 de fevereiro de 2014 11:18
  • Giovani, 

    Deixei ativo os Actives e Plug ins não deu certo. Deixei de forma do modo de compatibilidade e deu certo.

    Ele funciona em outros browser, mas se eu força colocando a instrução, conforme abaixo, não funciona, pois a tela vem em branco. 

    <meta http-equiv="X-UA-Compatible" content="IE=9"/>

     

    Kelsen Nunes

    terça-feira, 18 de fevereiro de 2014 12:55