locked
Qual seria melhor maneira? RRS feed

  • Pergunta

  • Olá a todos,

    Estou trabalhando com uma planilha mais tenho dificuldade para fazer uma formula se alguem poder me ajudar agradeço.

     

    Tenho que fazer o seguinte.

     

    QUANDO X=20 E Y=80   W TERIA QUE SER 300

    QUANDO X=20 E Y=90   W TERIA QUE SER 400

     

    e assim por diante.

    ps. usei x, y e w como exemplo

    tentei fazer com =se mas sem sucesso :/

     

    sábado, 1 de janeiro de 2011 19:04

Todas as Respostas

  • Use o E junto com o SE. Supondo que o valor de X esteja na coluna A, o valor de Y esteja na coluna B e o resultado de W deve aparecer na coluna C.

    =SE(E(A2=20;B2=80);300;SE(E(A2=20;B2=90);400;"Nenhum valor"))

    E assim poderíamos continuar com outros testes.

    =SE(E(A2=20;B2=80);300;SE(E(A2=20;B2=90);400;"Nenhum valor")) - se ambos forem verdadeiros, mostra 300.

    =SE(E(A2=20;B2=80);300;SE(E(A2=20;B2=90);400;"Nenhum valor")) - se ambos forem verdadeiros, mostra 400

    E se não for nenhum dos anteriores, exibe a mensagem "Nenhum valor"


    Fernando Nishimura de Aragão
    Se a resposta foi útil, clique no ícone ao lado para avaliar positivamente o participante. Obrigado.
    domingo, 2 de janeiro de 2011 00:15
  • sua formula tb da certo,

     

    Pesquisando comei fiz uma assim,

     

    =SE(D14=80;SE(C14=20;$Traços.C2;"");SE(D14=100;SE(C14=20;$Traços.C3;"")))

     

    sabe como posso deixar a parte "$Traços.C2" fixa?

    tp quando eu arrasto ela pra debaixo ficar as formas tb o ""$Traços.C2"" muda tb no caso ele vai pra $Traços.C3, $Traços.C4 e cia...

    :/

    domingo, 2 de janeiro de 2011 00:39
  • Para tornar fixa, coloque como $Traços.$C$2
    Fernando Nishimura de Aragão
    Se a resposta foi útil, clique no ícone ao lado para avaliar positivamente o participante. Obrigado.
    domingo, 2 de janeiro de 2011 00:45
  • vlw :D

     

    ultima pergunta prometo :>

     

    as demais que ainda nao estao preenchidas ficam como falso, tem como tirar?

    se nao tiver nao tem problema so pra saber msm.

    domingo, 2 de janeiro de 2011 01:06
  • Pode perguntar o quanto precisar. Acrescente ali no final, antes de fechar os últimos parênteses o ponto e vírgula seguido de abre-fecha aspas duplas.

    =SE(D14=80;SE(C14=20;$Traços.C2;"");SE(D14=100;SE(C14=20;$Traços.C3;"");""))


    Fernando Nishimura de Aragão
    Se a resposta foi útil, clique no ícone ao lado para avaliar positivamente o participante. Obrigado.
    domingo, 2 de janeiro de 2011 01:13
  • tÁ MUITO COMPLICADO ISSO COM ESSE MONTE DE se()

     

    Porque vc nao cria uma tabela auxiliar onde vc coloca os valores de x da horizontal e os de y na vertical e no meio coloca os correspondentes a W ?  Assim.

    K.......L........M......N..

    .........20......40.....50

    80.....300.....?........? 

    90.....400.....?........? 

     

    agora é só fazer um procv() associado ao corres(), assim

     

    =seerro( procv( B2 ; $k$2:$n$2 ; corresp( a2 ; $l$1:$n$1; 0)+1 ; 0 ) ; "" )

    pronto, essa simples fórmula aí vc pode copiar para onde quiser que não dá erro

     

    A vantagem de usar a tabela auxiliar é que vc pode ir lá mudar os valores da tabela e num precisa mudar uma vírgula na fórmula, sem falar que fica bem mais claro e fácil de entender a correspondencia entre os valores possíveis para b2 e a2 

     


    João Eurico Consultor Manguetown - Brazil
    domingo, 2 de janeiro de 2011 18:36
  • Acho que nao consigo fazer, mas vou tentar!

    Teria alguma apostila ou algo pra me auxiliar?

     

    Ty

     

     

    domingo, 2 de janeiro de 2011 20:42
  • Num tem bicho !!

    Vc consegue criar a tabela ? é super fácil, reserve uma área da planilha e coloque a tabelinha com os valores possíveis. Depois é só usar a fórmula que passei, num tem complicação. Fica super simples.

    Experimente, mas se tiver dificuldade, me chame no msn jeal65@hotmail.com


    João Eurico Consultor Manguetown - Brazil
    domingo, 2 de janeiro de 2011 20:46