none
Asp .NET ScriptManager RRS feed

  • Pergunta

  • Bom dia Amigos,

    Estou com um problema e apos um dia sem solução resolvi pedir ajuda aqui, é o seguinte.

    Minha aplicação depois de algum tempo começou a  me exibir a seguinte mensagem:

    Error 103 The type 'System.Web.UI.ScriptManager' exists in both 'c:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\meusite\cafc2537\3c7ec70b\assembly\dl3\f530e51a\0080ab76_d53cc701\System.Web.Extensions.DLL' and 'c:\Windows\assembly\GAC_MSIL\System.Web.Extensions\3.5.0.0__31bf3856ad364e35\System.Web.Extensions.dll' D:\WorkArea\VSS2\meusite\meusite\App_Code\BasePage.cs 37 13 D:\...\meusite\

    Alguem sabe qual o motivo deste erro, ou me dar uma orientação de onde posso encontrar uma solução para este problema?

    Desde já agradeço a todos.

    quinta-feira, 17 de maio de 2012 12:42

Respostas

  • Boa Tarde a todos,

    Resolvi meu problema, como o meu projeto é um "Web Site", a referência estava na pasta bin, precisei apenas remover essa referencia e adiciona-la novamente que o problema desapareceu.

    Obrigado pela atenção de todos.


    Francisco Silva Analista de Sistemas

    quinta-feira, 17 de maio de 2012 17:25

Todas as Respostas

  • Francisco,

    A mensagem diz que  o assembly existe na pasta da sua aplicação e no GAC.

    Tente isso:

    1. Feche todas as janelas do Visual Studio;
    2. Vá até a pasta "c:\Windows\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files";
    3. Apague tudo que existir nela;
    4. Abra seu projeto novamente e compile.

    Abraço,


    Carlos Eduardo Ferreira

    quinta-feira, 17 de maio de 2012 13:12
  • Bom dia Carlos,

    fiz o procedimento que você me orientou mas infelizmente não deu certo, a pasta foi recriada e a mensagem voltou a aparecer.

    Obrigado pela ajuda.

    quinta-feira, 17 de maio de 2012 13:53
  • Francisco,

    Tente isso:

    Adicione o atributo batch="false" no elemento "compilation" do web.config.

    <configuration ...>
      <system.web>
        <compilation ... batch="false"/>
          ...

    Referência:

    http://stackoverflow.com/questions/371426/asp-net-error-the-type-foo-exists-in-both-temp1-dll-and-temp2-dll


    Carlos Eduardo Ferreira

    quinta-feira, 17 de maio de 2012 14:30
  • Bom dia Carlos,

    Fiz novamente o procedimento sugerido por você e li sua referência e mesmo assim o problema ainda continua.

    Muito Obrigado pela atenção


    Francisco Silva Analista de Sistemas

    quinta-feira, 17 de maio de 2012 14:50
  • Boa Tarde a todos,

    Resolvi meu problema, como o meu projeto é um "Web Site", a referência estava na pasta bin, precisei apenas remover essa referencia e adiciona-la novamente que o problema desapareceu.

    Obrigado pela atenção de todos.


    Francisco Silva Analista de Sistemas

    quinta-feira, 17 de maio de 2012 17:25