none
Criar uma nova planilha contando valores repedidos de uma determinada área RRS feed

  • Pergunta

  • Tenho uma planilha com uma coluna onde coloco datas. Eu preciso que estas estejam automaticamente em uma nova planilha distintamente e que conte quantas vezes a data se repete.

    Exemplo:

    Data

    11/06/2016

    30/06/2016

    06/07/2016

    23/08/2016

    11/06/2016

    30/06/2016

    06/07/2016

    Na nova planilha teremos:

    Data                      NrVezes

    11/06/2016                2

    30/06/2016                2

    06/07/2016                2

    23/08/2016                1

    Alguém pode me ajudar com uma função?

    Agradeço muito a ajuda de vocês.

    quinta-feira, 22 de setembro de 2016 20:10

Todas as Respostas

  • Dá para fazer via fórmula. Veja uma proposta utilizando fórmula matricial para gerar a lista dinâmica sem repetição, suponde que as datas serão lançadas na plan1 no intervalo A2:A500.

    A fórmula matricial aplicada na imagem é:

    =SEERRO(DESLOC(Plan1!$A$1;CORRESP(MAIOR(CONT.SE(Plan1!$A$2:$A$500;">"&Plan1!$A$2:$A$500)*(CONT.SE(INDIRETO("plan1!A2:A"&LIN(Plan1!$A$2:$A$500));Plan1!$A$2:$A$500)=1);SE(LIN(A1)>SOMA(SE(FREQÜÊNCIA(SE(NÚM.CARACT(Plan1!$A$2:$A$500)>0;CORRESP(Plan1!$A$2:$A$500;Plan1!$A$2:$A$500;0);"");SE(NÚM.CARACT(Plan1!$A$2:$A$500)>0;CORRESP(Plan1!$A$2:$A$500;Plan1!$A$2:$A$500;0);""))>0;1));-1;LIN(A1)));CONT.SE(Plan1!$A$2:$A$500;">"&Plan1!$A$2:$A$500)-(Plan1!$A$2:$A$500="");0);0);"")

    Essa fórmula deve ser inserida com CTRL+SHIFT+ENTER.


    Rafael Kamimura - http://excelmaniacos.com

    quinta-feira, 22 de setembro de 2016 20:42
  • Rafael muito obrigada por seu retorno, Porém, como inserir com CTRL+SHIFT+ENTER.?

    Meu excel é versão 2000

    quinta-feira, 22 de setembro de 2016 22:20
  • Boa noite Lidia.

    Penso que uma Tabela Dinâmica seja mais simples e flexível. Já tentou utilizar?

    Abraço.


    Filipe Magno

    sexta-feira, 23 de setembro de 2016 01:41
  • Ola Felipe,

    Gostaria de fazer via fórmula, ou função, alguma coisa automática, se fosse possível.

    A área em que serão digitadas as datas é pequena. Minha intenção é que ao digitar a data outra planilha é alimentada com as informações que eu digitar, ou seja, em outra planilha estaria gerando um totalizador.

    Exemplo:

    As datas serão colocadas na coluna B1:B10 da plan1;

    Se eu digito uma data na cel B1 da plan1, a plan2 automaticamente coloca na cel B1 a data digitada e totaliza com 01

    Se eu acrescentar a mesma data na cel B2 da plan1, automaticamente verifica que já existe esta data o total fica igual a 02, senão ele acrescenta a data na próxima linha e totaliza 01

    Se eu colocar outra data na terceira linha, ele verifica se a data ja existe, se existir ele acrescenta mais um no total senão acrescenta a data e totaliza 01 

    e assim por diante até eu digitar a ultima célula, que é b10 




    sexta-feira, 23 de setembro de 2016 18:19
  • Alguém poderia me responder se é possível executar o que estou precisando?

    terça-feira, 27 de setembro de 2016 15:42
  • Amigos,

    Consegui resolver com tabela dinâmica msm. Muito obrigada

    sexta-feira, 30 de setembro de 2016 13:53