none
Execução não pára no Breakpoint RRS feed

  • Pergunta

  • Oi pessoal,

     

    Estou com um problema que deve ser fácil de resolver, mas está me dando a maior dor de cabeça. Quando executo o programa com o Visual Studio, utilizando Start Debugging a execução não pára no Breakpoint.

     

    Eu coloco o Breakpoint clicando na barra lateral do código, ou com F9, ou no menu Debug > Toggle Breakpoint, e a execução vai direto.

     

    Quando ocorre uma exceção ele passa direto também, só aparece o erro no browser. E olhem que mandei ir no modo Debug...

     

    Já futuquei e não consegui. Eu imagino que seja algo de configuração, mas não faço idéia de como resolver isso.

     

    Estou usando Windows Vista Ultimate, VS 2005 e instalei o SP1 do VS e o SP1 do VS para Vista.

     

    Valeu, abraço.

    quarta-feira, 18 de abril de 2007 19:12

Respostas

  • Oi !

     

    Verifique se você está executando a aplicação em modo debug ou modo release.

     

    Além disso, verifique se você iniciou o visual studio com permissões elevadas (clicando no botão direito, run as administrator)

     

    []'s

     

    quarta-feira, 18 de abril de 2007 19:22

Todas as Respostas

  • Recompile e veja se na pasta bin tem um arquivo com o mesmo nome do seu assembly, mas com a extensão .pdb.
    quarta-feira, 18 de abril de 2007 19:21
  • Oi !

     

    Verifique se você está executando a aplicação em modo debug ou modo release.

     

    Além disso, verifique se você iniciou o visual studio com permissões elevadas (clicando no botão direito, run as administrator)

     

    []'s

     

    quarta-feira, 18 de abril de 2007 19:22
  • Cara, consegui com Executar como administrador.

     

    Mas quando você diz modo debug ou modo release, o release é o Run Without Debug?

     

    Além disso, como eu faço para deixar o Visual Studio sempre como administrador? Tem algo relacionado com o meu usuário no windows?

     

    Valeu.

    quarta-feira, 18 de abril de 2007 19:33
  • Oi !

     

    Não, eu estava me referindo a formas de compilação, mas se funcionou como administrator então era isso, tá resolvido.

     

    Quando a fazer sempre iniciar assim, bem, acabou acontecendo por acidente no meu Vista, então não lembro bem como cheguei nisso. Acho que clique com o botão direito e fiz um pin do visual studio  no menu start ou algo assim, ou o Vista identificou, pelo meu padrão de uso, que eu precisava desta aplicação sempre rodando como administrator e passou a sempre pedir a elevação ao iniciar o visual studio...

     

    []'s

     

    quarta-feira, 18 de abril de 2007 19:43
  • Vlw, ajudou.
    quarta-feira, 18 de abril de 2007 19:47
  • Estou postando pois achei o local onde é possível colocar os programas como administradores.

     

    É necessário que você configure nas propriedades do arquivo executável.

     

    No caso do Visual Studio, é o arquivo devenv.exe, na pasta Microsoft Visual Studio 8\Common7\IDE.

     

    Clique com o botão direito no arquivo e na aba Compatibilidade marque o Checkbox "Executar este programa como administrador". Sequiser aplicar isso para qualquer usuário, clique em "Mostrar configurações de todos os usuários" e marque o mesmo Checkbox, que está no fim da janela.

     

    Era simples, mas até descobrir...

     

    Valeu.

    quinta-feira, 19 de abril de 2007 12:37
  • Oi !

     

    Identifiquei que você chega no mesmo local se clicar com o botão direito no programa pelo menu start (sem ter que buscar o .exe pelo explorer) e clicar em properties.

     

    Mas, como disse, não lembro de ter feito isso não, existe algum outro caminho mais "automático".

     

    []'s

     

    quinta-feira, 19 de abril de 2007 12:54
  • Mas se vc fizer através deste caminho, nunca mais irá precisa clicar com botão dirteito no atalho. Pois o Windows já irá reconhecer sua permissão como Administrador.

     

    Depende de como cada um preferir. Eu prefiro assim, pois tenho mais de um atalho para o Visual Studio, fica mais fácil.

     

    Valeu.

    terça-feira, 24 de abril de 2007 13:16
  • Eu estou tendo este mesmo problema com um pequeno diferencial: estou usando o SourceSafe também. Então, quando eu tento rodar como administrador, não aparece a tela para logar com o meu usuário. Outra coisa: assim que eu abro o projeto, aparentemente o VS2005 não consegue encontrar o caminho para o projeto e eu tenho que trabalhar offline. Isso é normal?
    sexta-feira, 13 de julho de 2007 20:14