locked
Atribuir valor 'vazio' a uma celula em Excel RRS feed

  • Pergunta

  • Tenho, em uma célula (A2), uma fórmula do tipo: =SE(ÉCÉL.VAZIA(A1);"";A1). Ou seja, eu quero que, se a célula A1 estiver vazia, que o valor da A2 seja vazio também.

     

    O problema é que eu estou usando esta célula A2 como valor para plotar um gráfico e, pelo o que vi, o gráfico entende que o valor "" retornado de uma fórmula é diferente de vazio. E então, o gráfico não sai da maneira que quero.

     

    Eu precisa então de uma fórmula do tipo: =SE(ÉCÉL.VAZIA(A1);VAZIO,A1). Existe isso?

     

    Desde já agradeço.

    quinta-feira, 3 de fevereiro de 2011 12:02

Respostas

Todas as Respostas

  • Tenho, em uma célula (A2), uma fórmula do tipo: =SE(ÉCÉL.VAZIA(A1);"";A1). Ou seja, eu quero que, se a célula A1 estiver vazia, que o valor da A2 seja vazio também.

     

    O problema é que eu estou usando esta célula A2 como valor para plotar um gráfico e, pelo o que vi, o gráfico entende que o valor "" retornado de uma fórmula é diferente de vazio. E então, o gráfico não sai da maneira que quero.

     

    Eu precisa então de uma fórmula do tipo: =SE(ÉCÉL.VAZIA(A1);VAZIO,A1). Existe isso?

     

    Desde já agradeço.

    Detalhe: eu fiz um teste em VBA, e vi que realmente existem os valores "" e o VAZIO. Se eu faço um teste de igualdade ( if(Range("W16").Value = Range("X11").Value ), sendo W16 igual a "" e X11 igual a Vazio, retorna true, mas o gráfico do excel só entende que um valor não contém nada de neste tiver vazio em vez de ""...
    quinta-feira, 3 de fevereiro de 2011 12:10
  • Já encontrei a resposta neste link:

    http://www.computing.net/answers/office/creating-blank-cells-in-excel/2549.html

     

    Posto aqui para caso alguém esteja com a mesma dúvida.

     

    PS: repare que o equivalente de NA() no excel em português é NAO.DISP()

     

    abraços

    • Marcado como Resposta Leonardo_Cruz quinta-feira, 3 de fevereiro de 2011 12:31
    quinta-feira, 3 de fevereiro de 2011 12:27