locked
Ajuda com fórmula para calcular total de acordo com opções RRS feed

  • Pergunta

  • Quem puder e souber me ajude!

    Supondo que eu tivesse uma tabela conforme abaixo como é que eu faria para ter, em uma célula à parte, o total de aviões que são brancos e particular (não que usar filtro). Se eu quisesse saber quantos aviões tem no CAMPO1 eu usaria =CONT.SE( A2:A13;"AVIÃO), no entanto a comparação usa 3 colunas distintas. Será que há a possibilidade de criar a fórmula usando a função mencionada aninhando-a várias vezes? 

     

                 A              B                          C

    1     CAMPO1    CAMPO2            CAMPO3

    2     CARRO       BRANCO            PARTICULAR

    3     MOTO         AZUL                  ALUGUEL

    4     AVIAO        BRANCO            ALUGUEL

    5     AVIAO        BRANCO            PARTICULAR

    6     AVIAO        AMARELO          ALUGUEL

    7     MOTO         AZUL                  PARTICULAR

    8     MOTO         VERDE               PARTICULAR

    9     AVIAO        AMARELO          PARTICULAR

    10    MOTO         AZUL                  ALUGUEL

    11    CARRO       BRANCO            ALUGUEL

    12    CARRO       PRETO               PARTICULAR

    13    AVIAO        AMARELO          ALUGUEL

    14    AVIAO        AMARELO          PARTICULAR

     

    Obrigado,

    Alexandre Magno

     

    terça-feira, 10 de junho de 2008 22:21

Respostas

  • Use a seguinte fórmula:

    Code Snippet
    =SOMARPRODUTO(($A$2:$A$14="AVIAO")*($B$2:$B$14="BRANCO")*($C$2:$C$14="PARTICULAR"))

     

     

    [ ]s

    terça-feira, 10 de junho de 2008 23:50
  • Mais uma vez, obrigado pelo ajuda. A formula é exatamentente o que eu queria.
    quarta-feira, 11 de junho de 2008 17:05

Todas as Respostas

  • Use a seguinte fórmula:

    Code Snippet
    =SOMARPRODUTO(($A$2:$A$14="AVIAO")*($B$2:$B$14="BRANCO")*($C$2:$C$14="PARTICULAR"))

     

     

    [ ]s

    terça-feira, 10 de junho de 2008 23:50
  • Mais uma vez, obrigado pelo ajuda. A formula é exatamentente o que eu queria.
    quarta-feira, 11 de junho de 2008 17:05