none
Instalação de Serviço do Windows (Windows Service) RRS feed

  • Pergunta

  • Pessoal, boa noite!

    Estou tentando criar um seriço no Windows XP utilizando VS 2008 com C#. Fiz uma aplicação para teste, utilizando um projeto "Windows Service".

    É algo bem simples, gera uma mensagem (MessageBox) a cada 3 segundos. A compilação do código está OK. Gerei o instalador através do Menu: Build-> Publish.

    Finalmente tentei fazer a instalação do serviço através do aplicativo "InstallUtil.exe", digitando o seguinte comando no prompt: InstallUtil \\Path\Setup.exe
    E gerou a mensagem de erro: Exception occourred while initializing the installation: System.IO.FileNotException: Could not load file or assembly 'file:///C:\Documents' or one of its dependencies. O sistema não pode encontrar o arquivo especificado..

    Quando eu tento executar o aplicativo manualmente, o sistema exibe um pop-up com a mensagem: Cannot start service from the command line or a debugger. A Windows Service must first be installed (using installutil.exe) and the started with the ServerExplorer, Windows Services Administrative tool or the NET START command.

    Alguém tem idéia de qual é o problema? Procurei aqui no fórum e em diversos outros e não encontrei solução.

    Agradeço a atenção....


    Abraços

    Miguel Sotti

    Miguel Sotti Systems Analyst E-mail: m_sotti@hotmail.com Website: http://msotti.blogspot.com www.msotti.hog.com.br
    segunda-feira, 1 de junho de 2009 22:09

Respostas

  • Caros,

    "Batendo cabeça", consegui fazer o processo funcionar. Eu estava fazendo algumas coisas erradas. Vou postar no meu blog (essa semana) um "tutorial" para criar o serviço mencionando os erros que cometi, caso alguém precise.

    Endereço do blog: http://msotti.blogspot.com/



    Abraços

    Miguel Sotti


    Miguel Sotti Systems Analyst E-mail: m_sotti@hotmail.com Website: http://msotti.blogspot.com www.msotti.hog.com.br
    • Sugerido como Resposta pcfviana quarta-feira, 2 de dezembro de 2009 11:45
    • Marcado como Resposta Harley AraujoModerator quinta-feira, 29 de dezembro de 2011 12:12
    quarta-feira, 3 de junho de 2009 14:14

Todas as Respostas

  • Caros,

    "Batendo cabeça", consegui fazer o processo funcionar. Eu estava fazendo algumas coisas erradas. Vou postar no meu blog (essa semana) um "tutorial" para criar o serviço mencionando os erros que cometi, caso alguém precise.

    Endereço do blog: http://msotti.blogspot.com/



    Abraços

    Miguel Sotti


    Miguel Sotti Systems Analyst E-mail: m_sotti@hotmail.com Website: http://msotti.blogspot.com www.msotti.hog.com.br
    • Sugerido como Resposta pcfviana quarta-feira, 2 de dezembro de 2009 11:45
    • Marcado como Resposta Harley AraujoModerator quinta-feira, 29 de dezembro de 2011 12:12
    quarta-feira, 3 de junho de 2009 14:14
  • Ué, cadê o tutorial que vc falou? Estou precisando dele! =)
    terça-feira, 13 de julho de 2010 21:04