none
Problema na seleção de conexão do Schema Comparison RRS feed

  • Pergunta

  • Pessoal,

    Há tempos utilizo as ferramentas de comparação de banco de dados do Visual Studio (Schema Compare e Data Compare).

    Agora na versão 2010 apareceu um pequeno problema que não existia nas versões anteriores. É um pequeno detalhe, mas atrapalha bastante.

    Quando eu crio um "New Schema Comparison", aparece uma tela onde devo informar a conexão do primeiro banco (source) e o segundo banco (target). Eu utilizo dezenas de bancos, portanto, tenho dezenas de conexões. Por via de regra, eu devo fazer várias comparações seguidas de vários bancos.

    Nas versões anteriores: quando eu selecionava uma conexão na lista de combo, esta seleção permanecia "no mesmo lugar" da lista, ao abrir o combo novamente para selecionar uma outra linha seguida, bastava selecionar a próxima linha.

    Na versão 2010: quando seleciono uma conexão na lista do combo, a seleção vai para o topo da lista, ao abrir o combo novamente eu devo varrer a lista novamente até encontrar a nova linha.

    Parece um problema simples, mas quando se trabalha com dezenas de conexões com nomes parecidos, este comportamento atipico do combo pode resultar em inumeros enganos e problemas. Coisas que já aconteceram comigo.

    Por ser um comportamente diferente de todos os combos e ser diferente das versões anteriores, suponho que seja um bug que foi introduzido na versão 2010.

    Curisomente, o Data Compare continua funcionando corretamente como nas versões anteriores, o problema só existe com o Schema Compare.

    Alguém sabe se a MS tem algum patch de correção para esse bug? Ou mesmo algum lugar onde eu possa relatar este problema para uma futura correção?

    Grato desde já.

     

    Utilizo:

    Microsoft Visual Studio 2010
    Version 10.0.30319.1 RTMRel
    Microsoft .NET Framework
    Version 4.0.30319 RTMRel

    Installed Version: Ultimate

     

    terça-feira, 10 de agosto de 2010 17:20

Respostas

  • Prezado,

    Não sei se já chegaram a reparar nesse "problema". Talvez tenham realmente alterado o comportamento padrão na versão 2010, mas, é estranho se isso aconteceu porque, como você mesmo falou, o Data Compare continua com o comportamento antigo.

    Enfim, nos fóruns aqui em PT-BR, acredito que você não vá conseguir a visibilidade necessária para o time de produto verificar essa questão, então, sugiro que você poste no fórum da ferramenta (VS DB Dev Tools) da MSDN EN-US, onde, com certeza, pessoas do time de produto acompanham o fórum e podem te dar uma resposta mais sólida quanto a esse assunto:

    http://social.msdn.microsoft.com/Forums/en-US/vstsdb/threads


    André Alves de Lima
    Visite o meu site: http://andrealveslima.spaces.live.com
    Me siga no Twitter: @andrealveslima
    terça-feira, 10 de agosto de 2010 21:13
    Moderador

Todas as Respostas