none
Problemas com site RRS feed

  • Pergunta

  • estou com um problema vou tentar explicar..

    é assim tenho um site "X" que possuí um banco "X" ok.  hospedados na uolhost

    no caso coloquei uma pasta dentro do site "X" dentro dela terá um site "Y" e esse site recebera um banco "Y"

    o site "Y" é igual o visual do site "X" mas o banco é zero ate ai ok. Então o problema começa o banco "Y" ja esta pronto na uol. 

    quando vou testar o site "Y" local ele está como deveria mas ao subir para a hospedagem o site "Y" abre o banco "X" mesmo deletando as dll de conexão  do banco ele ainda abre o "X" alterando alguma palavra e subindo a nova dll ele n modifica nada..

    se alguém souber de algo obrigado. 

     
    quinta-feira, 15 de novembro de 2012 18:32

Respostas

  • Meu problema ja foi solucionado apos criar uma nova classe interna de conexão e usar a dll Microsoft.Web.Infrastructure.dll

    tudo esta funcionando normal.

    Obrigado a todos

    • Marcado como Resposta Inis Oliveira sábado, 1 de dezembro de 2012 03:34
    sábado, 1 de dezembro de 2012 03:34

Todas as Respostas

  • Inis, Boa tarde

    A sua connectionString esta no web.config?

    você tem um web.config dentro da pasta Y?


    Bruno Viegas D. Ribeiro

    Analista Desenvolvedor de Sistemas
    www.brunoviegas.com.br
     

    quinta-feira, 15 de novembro de 2012 20:14
  • Vai no painel da uol e seleciona a pasta "Y" como um aplicativo, e n esquece de fazer exemplo.. "Y_banco", poem um prefixo no nome do banco, caso os duas maneiras nao funcionem, posta aqui a string de conexao do Site Y com o banco, e a do X para que a gente possa analizar...

    Thiii =)

    sexta-feira, 16 de novembro de 2012 00:38
  • consegui colocar o "Y" como aplicativo não estava indo antes mas agora esta assim quando vou entrar no site

    Security Exception

    Description: The application attempted to perform an operation not allowed by the security policy.  To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file. 

    Exception Details: System.Security.SecurityException: Request for the permission of type 'MySql.Data.MySqlClient.MySqlClientPermission, MySql.Data, Version=6.5.4.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d' failed.

    domingo, 25 de novembro de 2012 22:34
  • Agora mude o trust level do aplicativo.

    http://msdn.microsoft.com/en-us/library/wyts434y(v=vs.100).aspx


    Thiii =)

    segunda-feira, 26 de novembro de 2012 01:15
  • Como posso configurar o trust level para esse caso você poderia me explicar ?

    Obrigado!

    segunda-feira, 26 de novembro de 2012 02:23
  • vai no seu web.config e coloca

    <system.web>
      <securityPolicy>
        <trustLevel name="Full" policyFile="internal"/>
      </securityPolicy>
    </system.web>
    

    segunda-feira, 26 de novembro de 2012 11:29
  • vai no seu web.config e coloca

    <system.web>
      <securityPolicy>
        <trustLevel name="Full" policyFile="internal"/>
      </securityPolicy>
    </system.web>

    então coloque dentro da tag system.web mas o problema ainda permanece.

    segunda-feira, 26 de novembro de 2012 22:40
  • Meu problema ja foi solucionado apos criar uma nova classe interna de conexão e usar a dll Microsoft.Web.Infrastructure.dll

    tudo esta funcionando normal.

    Obrigado a todos

    • Marcado como Resposta Inis Oliveira sábado, 1 de dezembro de 2012 03:34
    sábado, 1 de dezembro de 2012 03:34