none
Problema visualização RRS feed

  • Pergunta

  • Olá,

    Estou mostrando meu report de forma remota, quando eu abro no navegador o reporting services ele mostra tudo no layout certinho, mais quando faço remote ele mostra o header e footer alinhado mais, o conteúdo que tem os dados ele não aparece alinhado fica uns 10 a 15% para o lado direito da página,alguém já teve esse problema? lembrando que todos os campos estão com mesmo tamanho.

    segunda-feira, 16 de agosto de 2010 15:26

Respostas

Todas as Respostas

  • Seilor,

    Como assim de forma remota?


    André Alves de Lima
    Visite o meu site: http://andrealveslima.spaces.live.com
    Me siga no Twitter: @andrealveslima
    segunda-feira, 16 de agosto de 2010 17:26
    Moderador
  • Nesse modelo

    //Informa o modo de execução do relatório (Local ou Remoto)
                    ReportViewerGeneral.ProcessingMode = ProcessingMode.Remote;
                    //Informar respectivamente as URLs do Servidor Report Service e do Relatório a ser executado
                    ReportViewerGeneral.ServerReport.ReportServerUrl = new Uri( "http://localhost:8080/ReportServer" );
                    ReportViewerGeneral.ServerReport.ReportPath = "/GITDW/"+DdlReport.SelectedValue;
                    ReportViewerGeneral.ServerReport.ReportServerCredentials = new ReportCredentials( "User" , "Pass" , "" );
                    //Vamos criar a atribuir valores para os parametros
                    IEnumerable<ReportParameter> reportParams = LoadParameters();
                    //Atribumos os parametros criados para o relatorio
                    ReportViewerGeneral.ServerReport.SetParameters( reportParams );
                    //Desabilita o barra de parametros do Report viewer
                    ReportViewerGeneral.ShowParameterPrompts = false;
                   
                    //Atualiza o relatorio para exibição
                    ReportViewerGeneral.ServerReport.Refresh();
                   
                    ReportViewerGeneral.Visible = true;
                    modalFormReports.Show();
                    UpReports.Update();

     

    é muito estranho quando rodo direto no server do reporting server roda certinho, quando abro no aspx ele desalinha, e quando imprimo ele fica certo

    segunda-feira, 16 de agosto de 2010 18:03
  • Já achei o problema era um arquivo css que estava pegando todas as td e fazendo um padding left :)
    segunda-feira, 16 de agosto de 2010 18:19