none
Qual problema em usar marcação da tag <label for no asp.net ? RRS feed

  • Pergunta

  • Olá pessoal, Bom dia !

    EStou criando um formulário com asp.net e visual studio 2013, estou utilizando a tag dessa forma:

    <label for="txtEXAME">QUAL?</label>
                <asp:TextBox runat="server" ID="txtEXAME"  class="form-control" Width="482px"></asp:TextBox>

    o Visual studio indica que :
    Cannot resolve id="txtEXAME", em todas as marcações porém está funcionando normalmente ao executar aplicação.

    e Também ao utilizar 

     <asp:TextBox runat="server" type="number" ID="txtIDADE" required="required" placeholder="Digite sua idade" class="form-control" Width="482px"></asp:TextBox>

    Eu esotu conseguindo digitar letras onde deveria ser apenas número.

    No top do meu form e coloquei o atributo 

    <!DOCTYPE html> e dentro da tag <head> o atributo <meta charset="utf-8"/>

    Alguém consegue ajudar por favor ?



    Abs, Adriano_SP

    quinta-feira, 30 de abril de 2015 12:41

Respostas

  • Adriano, acontece que ao renderizar a página, o asp.net alterar o id dos componentes que estão dentro de um updatepanel.

    Aconselho que você utilize o asp:Label ou inves do Label. Segue um exempo:

    <asp:Label ID="lblTeste1" runat="server" CssClass="control-label col-md-1" AssociatedControlID="txtTeste1">Teste</asp:Label>
    <asp:TextBox ID="txtTeste1" runat="server" CssClass="form-control"></asp:TextBox>


    • Marcado como Resposta Adriano_SP quinta-feira, 30 de abril de 2015 14:44
    quinta-feira, 30 de abril de 2015 12:58

Todas as Respostas

  • Adriano, acontece que ao renderizar a página, o asp.net alterar o id dos componentes que estão dentro de um updatepanel.

    Aconselho que você utilize o asp:Label ou inves do Label. Segue um exempo:

    <asp:Label ID="lblTeste1" runat="server" CssClass="control-label col-md-1" AssociatedControlID="txtTeste1">Teste</asp:Label>
    <asp:TextBox ID="txtTeste1" runat="server" CssClass="form-control"></asp:TextBox>


    • Marcado como Resposta Adriano_SP quinta-feira, 30 de abril de 2015 14:44
    quinta-feira, 30 de abril de 2015 12:58
  • Alexandre, valeu pela ajuda, funcionou direitinho!

    Mas só para constar não estou utilizando updatepanel não man....


    Abs, Adriano_SP

    quinta-feira, 30 de abril de 2015 14:45