none
E necessário "startar" o Analysis Services no SQL 2008 ? Não estou conseguindo da deploy do Cubo RRS feed

  • Pergunta

  • Boa tarde,

    Instalei o Sql server 2008 em uma maquina para estudo, cria um "DW" ou "DataMart"

    Criei as tabela DIm e Fato, com sua respectivas chaves primarias e estrageiras, processei as dimensões primeiro mas quando vou processar o cubo da o seguinte erro 

    Processing Cube ACADEMICO02 failed

    Processing Measure Group 'Ft Evento' failed.
    Start time: 15/2/2013 17:15:14; End time: 15/2/2013 17:15:14; Duration: 0:00:00
    Processing Partition 'Ft Evento' failed. 50000 rows have been read.
    Error Messages 2
    Erros no mecanismo de armazenamento OLAP: A chave de atributo não foi encontrada durante o processamento: Tabela: 'dbo_ft_evento', Coluna: 'cd_local', Valor: '54270'. O atributo é 'Cd Local'. Erros no mecanismo de armazenamento OLAP: O registro foi ignorado porque a chave de atributo não foi encontrada. Atributo: Cd Local de Dimensão: Dim Local do Banco de Dados: ACADEMICO2, Cubo: ACADEMICO2, Grupo de Medidas: Ft Evento, Partição: Ft Evento, Registro: 54270.

    estava vendo em alguns foruns, e eles falavam e "startar" o Analysis Services

    como faço isso no 2008 ?

    abs



    sexta-feira, 15 de fevereiro de 2013 20:22

Respostas

  • Eduardo, boa noite

    Este erro não está relacionado com o serviço SSAS. Dê uma olhada neste id 54270 na coluna cd_local. No momento de processar o cubo o SSAS não está conseguindo relacionar este código com a sua dimensão. Podem existir ID's em sua tabela fato que não possui relacionamento com a sua tabela de dimensão. Verifique se suas chaves estrangeiras estão exatamente nos campos de relacionamento da medida com a dimensão.

    Abs.


    Eduardo Gomes - http://www.h1solucoes.com.br - Twitter: @edugp_sp

    sexta-feira, 15 de fevereiro de 2013 21:50
  • Andrade,

    Antes de realizar o processamento das suas dimensões, você esta conseguindo acessar os dados que estão em suas tabelas?


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]

    sábado, 16 de fevereiro de 2013 11:50
  • Olá Junior Galvão,

    via query ou DSV ?


    segunda-feira, 18 de fevereiro de 2013 18:57
  • Eduardo,

    Obrigado o erro era isso mesmo o id 54270  existia na fato mas não existia na dimensão por isso esse erro muito loco, kkkk

    obrigado 

    segunda-feira, 18 de fevereiro de 2013 19:11

Todas as Respostas

  • Eduardo, boa noite

    Este erro não está relacionado com o serviço SSAS. Dê uma olhada neste id 54270 na coluna cd_local. No momento de processar o cubo o SSAS não está conseguindo relacionar este código com a sua dimensão. Podem existir ID's em sua tabela fato que não possui relacionamento com a sua tabela de dimensão. Verifique se suas chaves estrangeiras estão exatamente nos campos de relacionamento da medida com a dimensão.

    Abs.


    Eduardo Gomes - http://www.h1solucoes.com.br - Twitter: @edugp_sp

    sexta-feira, 15 de fevereiro de 2013 21:50
  • Andrade,

    Antes de realizar o processamento das suas dimensões, você esta conseguindo acessar os dados que estão em suas tabelas?


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]

    sábado, 16 de fevereiro de 2013 11:50
  • Olá Junior Galvão,

    via query ou DSV ?


    segunda-feira, 18 de fevereiro de 2013 18:57
  • Eduardo,

    Obrigado o erro era isso mesmo o id 54270  existia na fato mas não existia na dimensão por isso esse erro muito loco, kkkk

    obrigado 

    segunda-feira, 18 de fevereiro de 2013 19:11
  • Eduardo, infelizmente o SSAS tem um grande problema pra reportar erros. É importante estar bem próximo a ferramenta e ter um conceito de DW bem apurado para "driblar" esses incovenientes.

    Abs.


    Eduardo Gomes - http://www.h1solucoes.com.br - Twitter: @edugp_sp

    segunda-feira, 18 de fevereiro de 2013 20:16
  • Andrade,

    Via query!!!!


    Pedro Antonio Galvão Junior [MVP | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados | SorBR.Net | Professor Universitário | MSIT.com]

    terça-feira, 19 de fevereiro de 2013 17:05
  • Sim, encontrei o erro via query !!!

    abs

    terça-feira, 5 de março de 2013 15:16
  • Como você esta conectar o localhost esta configurado corretamente? Apresenta alguma mensagem de erro? 


    Luciana Sampaio http://lucianasampaio.wordpress.com/

    domingo, 24 de março de 2013 18:16