none
Macro para inserir linha buscando Intervalo células RRS feed

  • Pergunta

  • Bom dia pessoal,

    Tenho uma mala direta (xls) com 30.000 contatos. Preciso inserir linhas em branco ao final de determinados intervalos, estes intervalos são fornecidos pelos Correios em uma outra planilha.

    Ex. 

    De 01000-001 até 01028-999 vai pro CDD SE SPM

    De 01029-000 até 01058-999 vai pro CDD AV SAO JOAO SPM

    De 01059-000 até 01099-999 vai pro CDD AL NOTHMANN SPM

    Gostaria de inserir/mesclar estes dados na minha mala direta conforme encerra cada intervalo.

    Alguém se habilita?

    quinta-feira, 15 de maio de 2014 15:19

Respostas

Todas as Respostas

  • Olá Guico,

    Estou migrando sua dúvida para o fórum especializado em VBA.


    Obrigado por contactar o fórum Microsoft Technet!

    quarta-feira, 28 de maio de 2014 17:35
    Moderador
  • Olá, poderia detalhar mais a explicação ou disponibilizar um extrato da pasta de trabalho que exemplifique sua estrutura de dados para sugerirmos uma solução?

    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    quinta-feira, 29 de maio de 2014 03:13
    Moderador
  • Olá Felipe!

    Não consigo postar imagem aqui! Tem algum segredo? rsrs

    Aguardo seu feedback. Obrigado!

    quinta-feira, 29 de maio de 2014 15:14
  • Use o SendSpace.com para fazer o upload de sua pasta de trabalho e, em seguida, copie o link gerado e poste aqui.

    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    quinta-feira, 29 de maio de 2014 23:41
    Moderador
  • Tá na mão: http://www.sendspace.com/file/oxysq7
    sexta-feira, 30 de maio de 2014 14:15
  • 1 - Coloque todas as planilhas na mesma pasta de trabalho.

    2 - Escreva na célula K2 da planilha MALA_FOLDER_AGENDA:

    =PROCV(1*[@[CON_CEP]];'ORDEM DE CEP'!$C$4:$F$7;4)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    sábado, 31 de maio de 2014 01:35
    Moderador
  • Felipe,

    Adicionei o procv, porém ele retorna apenas um resultado. Veja a imagem: http://www.sendspace.com/file/vjcn5x

    Na planilha toda ele retornou: CTC MOOCA SPM 
    terça-feira, 3 de junho de 2014 18:37
  • Estou entendendo que a coluna a retornar é a F. Se for a E, tente a fórmula a seguir:

    =PROCV(1*[@[CON_CEP]];'ORDEM DE CEP'!$C$4:$F$7;3)

    Se mesmo assim não der certo, gentileza disponibilizar uma pasta de trabalho com mais dados.


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    terça-feira, 3 de junho de 2014 22:35
    Moderador
  • Olá Felipe, bom dia!

    Independente da coluna ser E ou F, o que ocorre é o seguinte: quando faço o procv na planilha onde está a minha mala direta (MALA_FOLDER_AGENDA), o procv retorna apenas alguns dados da planilha do correio (ORDEM DE CEP).

    Veja no filtro do anexo (http://www.sendspace.com/file/pe6qfl), listou apenas CDD AV SAO JOAO SPM e CDD AL NOTHMANN SPM. Quando na verdade eu tenho vários destinos.

    Me corrija se eu estiver errado, mas o procv não deveria retornar todos os destinos que estão na coluna E da planilha ORDEM DE CEP?

    quarta-feira, 4 de junho de 2014 12:44
  • No caso, você terá que estender a tabela de busca para incluir todos os resultados:

    =PROCV(1*[@[CON_CEP]];'ORDEM DE CEP'!$C$4:$F$2566;3)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    quinta-feira, 5 de junho de 2014 00:22
    Moderador