none
Erro Sharepoint Web.Config RRS feed

  • Pergunta

  •  

    Boa Tarde a Todos

     

    Até pouco tempo o site do sharepoint estava funcionando corretamente, mais após a tentativa de compartilhar a pasta onde fica armazenado os sites do sharepoint aparece este erro

     

    Erro de Servidor no Aplicativo '/'.

    Erro no tempo de execução

    Descrição: Erro de um aplicativo no servidor. As atuais configurações de erro personalizadas para esse aplicativo impedem a exibição remota dos detalhes do erro do aplicativo (por motivos de segurança). No entanto, eles poderiam ser exibidos por navegadores em execução no servidor local.

    Detalhes: Para ativar os detalhes desta mensagem de erro específica para exibição em computadores remotos, crie uma marca <customErrors> dentro de um arquivo de configuração "web.config" localizado no diretório raiz do aplicativo de web atual. Essa marca <customErrors> deve ter o atributo "mode" definido como "Off".

    <!-- Arquivo de Configuração Web.Config -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>

    Observações: A página de erro atual que você está vendo pode ser substituída por uma página de erro personalizada modificando o atributo "defaultRedirect" da marca de configuração <customErrors> do aplicativo para apontar para um URL de página de erro personalizada.

    <!-- Arquivo de Configuração Web.Config -->
    
    <configuration>
        <system.web>
            <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
        </system.web>
    </configuration>

     

    Não sei o que fazer   , comecei a trabalhar com o sharepoint a pouco tempo. Se alguém puder me dar uma luz agradeceria mto.

     

    Obrigada

    quarta-feira, 30 de julho de 2008 17:59

Respostas

  •  

    Tente proceder da seguinte forma,

     

    Para termos melhores detalhes do erro que esta ocorrendo vamos desabilitar a opção CustomErrors do SharePoint para ver onde esta ocorrendo uma exception... para tal proceda da seguinte forma :

     

    Procure o Web.Config de seu portal, geralmenete ele esta instalado na pasta : C:\Inetpub\wwwroot\wss\VirtualDirectories\%Porta do Portal%\Web.Config

     

    Certifique-se de salvar um backup antes de proceder com a alteração.

     

    A seguir abra-o com o seu editor de preferencia e altere as seguintes tags :

     

    DE :

     

    <SafeMode MaxControls="200" CallStack="false" DirectFileDependencies="10" TotalFileDependencies="50"

    AllowPageLevelTrace="false">

     

    PARA :

     

    <SafeMode MaxControls="200" CallStack="true" DirectFileDependencies="10" TotalFileDependencies="50" AllowPageLevelTrace="false">

     

    e

    DE :

    <customErrors mode="On" />

     

    PARA :

    <customErrors mode="Off" />

     

    e

    <compilation batch="false" debug="false">

     

    PARA:

    <compilation batch="false" debug="true">

     

     

    Salveo e tome a ação que ocasionou no erro novamente.

     

    tomando essa ação será mostrada a exception que esta sendo retornada, assim vc terá mais detalhes do erro que esta ocorrendo, se a duvida persistir poste novamente.

     

    Abraço.

     

    sábado, 2 de agosto de 2008 22:08

Todas as Respostas

  •  

    Tente proceder da seguinte forma,

     

    Para termos melhores detalhes do erro que esta ocorrendo vamos desabilitar a opção CustomErrors do SharePoint para ver onde esta ocorrendo uma exception... para tal proceda da seguinte forma :

     

    Procure o Web.Config de seu portal, geralmenete ele esta instalado na pasta : C:\Inetpub\wwwroot\wss\VirtualDirectories\%Porta do Portal%\Web.Config

     

    Certifique-se de salvar um backup antes de proceder com a alteração.

     

    A seguir abra-o com o seu editor de preferencia e altere as seguintes tags :

     

    DE :

     

    <SafeMode MaxControls="200" CallStack="false" DirectFileDependencies="10" TotalFileDependencies="50"

    AllowPageLevelTrace="false">

     

    PARA :

     

    <SafeMode MaxControls="200" CallStack="true" DirectFileDependencies="10" TotalFileDependencies="50" AllowPageLevelTrace="false">

     

    e

    DE :

    <customErrors mode="On" />

     

    PARA :

    <customErrors mode="Off" />

     

    e

    <compilation batch="false" debug="false">

     

    PARA:

    <compilation batch="false" debug="true">

     

     

    Salveo e tome a ação que ocasionou no erro novamente.

     

    tomando essa ação será mostrada a exception que esta sendo retornada, assim vc terá mais detalhes do erro que esta ocorrendo, se a duvida persistir poste novamente.

     

    Abraço.

     

    sábado, 2 de agosto de 2008 22:08
  • Bom dia, revivendo um Post de mais de 5 anos:

    Possuo o Sharepoint 3 em um servidor W2K8 e hoje ele derepente resolveu apresentar a mensagem citada pela Pryazarias. Realizei o processo indicado e a mensagem agora é:

    Erro de Servidor no Aplicativo '/'.

    Classe não registrada

    Descrição: Ocorreu uma exceção não tratada durante a execução da atual solicitação da Web. Examine o rastreamento de pilha para obter mais informações sobre o erro e onde foi originado no código.

    Detalhes da Exceção: System.Runtime.InteropServices.COMException: Classe não registrada


    Erro de Origem:
    Exceção não tratada foi gerada durante a execução da atual solicitação da Web. As informações relacionadas à origem e ao local da exceção podem ser identificadas usando-se o rastreamento de pilha de exceção abaixo.

    Rastreamento de Pilha:
    [COMException (0x80040154): Classe não registrada
    ]
       System.DirectoryServices.DirectoryEntry.Bind(Boolean throwIfFail) +377694
       System.DirectoryServices.DirectoryEntry.Bind() +36
       System.DirectoryServices.DirectoryEntry.get_IsContainer() +31
       System.DirectoryServices.ChildEnumerator..ctor(DirectoryEntry container) +26
       System.DirectoryServices.DirectoryEntries.GetEnumerator() +25
       Microsoft.SharePoint.ApplicationRuntime.SPRequestModule.System.Web.IHttpModule.Init(HttpApplication app) +477
       System.Web.HttpApplication.InitModulesCommon() +65
       System.Web.HttpApplication.InitModules() +43
       System.Web.HttpApplication.InitInternal(HttpContext context, HttpApplicationState state, MethodInfo[] handlers) +729
       System.Web.HttpApplicationFactory.GetNormalApplicationInstance(HttpContext context) +298
       System.Web.HttpApplicationFactory.GetApplicationInstance(HttpContext context) +107
       System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +289
    


    Informações sobre a Versão: Microsoft .NET Framework Versão:2.0.50727.4247; Versão do ASP.NET:2.0.50727.4248

    Pode me ajudar?


    Júlio Evandro

    sexta-feira, 4 de abril de 2014 11:58