none
Problemas com o Vista Premium SP1, VS 2005, WM5 SDK e Mobile Device Center 6.1 RRS feed

  • Pergunta

  • Olá gente!

     

    Eu sou novo no desenvolvimento device mobile, e procurei muito antes de postar.

    O meu problema é que tenho uma aplicação pronta WM5 e tenho que fazer uma manutenção, ajustar algumas coisas e eu não consigo rodar ela por nada, quando vou debugar me dá um erro:"%CSIDL_PROGRAM_FILES%/pathApp/myapp.exe"

    isso é um exemplo nome do caminho e exe não são os da minha aplicação. Eu criei uma aplicação do zero para pocket, um simples hello world e funcionou.

    Eu sei que esse valor fica configurado nas propriedades do projeto, e vefiquei que os dois seguem o mesmo padrão.

    O outro problema é que não consigo usar o Mobile Device Center 6.1 com o emulador, eu vi em um aqui na camunidade que instalando virtual server 2007 e habilitando a rede ele funcionaria, mas não conegui, habilitei a rede o emulador até acessa a internet, mas o Mobile device center não connecta ao emulador.

     

    Galera isso tem tirado meu sono, por favor me ajudem.

     

    Agradeço a todos vocês.

     

     

    Eduardo

    sexta-feira, 22 de agosto de 2008 02:59

Respostas

  • Bom dia Eduardo,

     

    Sobre você nao conseguir rodar :

     

    * Clique com o botão direito sobre o projeto que voce colocou os forms e aperte na opção Propriedades.

    * Vá na aba Devices.

    * Na opção Deploy Option.

    * Escolha o emulador que voce esta utilizando no campo Target Device.

    * Na opção Output file folder Mude para \NomedoProjeto.

    * Salve as alterações e copile o projeto e teste.

     

    Sobre a comunicação com o emulador você vai fazer o seguinte :

     

    Iniciar o emulador Manualmente  :

     

    * Abra o seu projeto.

    * Vá na opção Tools -> Device Emulator Manager.

    * Clique com o botão direito sobre o emulador a ser utilizado e clique na opção Connect.

    * Clique com o botão direito sobre o emulador a ser utilizado e clique na opção Cradle.

    * Apos isso abra o Mobili Device.

     

    Inicir o emulador Após rodar o projeto :

     

    * O Emulador vai abrir.

    * Vá na opção Tools -> Device Emulator Manager.

    * Clique com o botão direito sobre o emulador a ser utilizado e clique na opção Cradle.

    * Apos isso abra o Mobili Device.

     

     

    Espero ter ajudado,

    Abraço....

    sexta-feira, 22 de agosto de 2008 11:45

Todas as Respostas

  • Bom dia Eduardo,

     

    Sobre você nao conseguir rodar :

     

    * Clique com o botão direito sobre o projeto que voce colocou os forms e aperte na opção Propriedades.

    * Vá na aba Devices.

    * Na opção Deploy Option.

    * Escolha o emulador que voce esta utilizando no campo Target Device.

    * Na opção Output file folder Mude para \NomedoProjeto.

    * Salve as alterações e copile o projeto e teste.

     

    Sobre a comunicação com o emulador você vai fazer o seguinte :

     

    Iniciar o emulador Manualmente  :

     

    * Abra o seu projeto.

    * Vá na opção Tools -> Device Emulator Manager.

    * Clique com o botão direito sobre o emulador a ser utilizado e clique na opção Connect.

    * Clique com o botão direito sobre o emulador a ser utilizado e clique na opção Cradle.

    * Apos isso abra o Mobili Device.

     

    Inicir o emulador Após rodar o projeto :

     

    * O Emulador vai abrir.

    * Vá na opção Tools -> Device Emulator Manager.

    * Clique com o botão direito sobre o emulador a ser utilizado e clique na opção Cradle.

    * Apos isso abra o Mobili Device.

     

     

    Espero ter ajudado,

    Abraço....

    sexta-feira, 22 de agosto de 2008 11:45
  • Oi Felipe,

    Muito obrigado pela sua ajuda, funcionou tudo perfeito.

    Muito obrigado mesmo.

    sábado, 23 de agosto de 2008 01:05