none
Conflito Jquery modalxautocompletar de editableDDL RRS feed

  • Pergunta

  • Caros,Pesquisei como fazer uma ddl editável no link:

    www.codeproject.com/Articles/290218/Custom-ASP-NET-Editable-DropDownList

    Segui exatamente o exemplo e atende as minhas necessidades,porém quando tento usá-lo num formulário que já tenho vários jquery`s que chamam modais,ocorre um conflito.

    Para que meu modal funcione preciso das seguintes bibliotecas(Vou dar nome a cada listagem .js):
    (1a listagem de.js):
        <link href="css/jquery-ui.css" rel="stylesheet" type="text/css" />
        <script src="Scripts/jquery-1.7.1.min.js.js" type="text/javascript"></script>
        <script src="Scripts/jquery-ui-1.9.2.custom.min.js" type="text/javascript"></script>
        <script src="Scripts/jquery.ui.position.js" type="text/javascript"></script>
        <script src="Scripts/jquery.ui.autocomplete.js" type="text/javascript"></script>
        <script src="Scripts//jquery.ui.combobox.js" type="text/javascript"></script> 

    Porém desta forma,no meu DDL editável,funciona apenas como um dropdown normal,e eu preciso da função dele de textbox com autocompletar.
    E sei exatamente como ativá-lo,é da seguinte forma (tenho que retirar o "jquery-ui-1.9.2.custom.min.js" e acrescentar os .ui.core.js, ui.widget.js e ui.button.js)ficando assim tudo:
    (2a listagem de.js):
        <link href="css/jquery-ui.css" rel="stylesheet" type="text/css" />
        <script src="Scripts/jquery-1.7.1.min.js.js" type="text/javascript"></script>
        <script src="Scripts/jquery.ui.core.js" type="text/javascript"></script>
        <script src="Scripts/jquery.ui.widget.js" type="text/javascript"></script>
        <script src="Scripts/jquery.ui.button.js" type="text/javascript"></script>
        <script src="Scripts/jquery.ui.position.js" type="text/javascript"></script>
        <script src="Scripts/jquery.ui.autocomplete.js" type="text/javascript"></script>
        <script src="Scripts/jquery.ui.combobox.js" type="text/javascript"></script> 

    E então meu DDL editável funciona normalmente como quero, como textbox com autocompletar.PORÉM meu modal para de funcionar aqui,logo se supõe que é pela falta do"jquery-ui-1.9.2.custom.min.js"-porém quando simplesmente acrescento ele na listagem acima:
    (3a listagem de.js):
        <link href="css/jquery-ui.css" rel="stylesheet" type="text/css" />
        <script src="Scripts/jquery-1.7.1.min.js.js" type="text/javascript"></script>
        <script src="Scripts/jquery-ui-1.9.2.custom.min.js" type="text/javascript"></script>
        <script src="Scripts/jquery.ui.core.js" type="text/javascript"></script>
        <script src="Scripts/jquery.ui.widget.js" type="text/javascript"></script>
        <script src="Scripts/jquery.ui.button.js" type="text/javascript"></script>
        <script src="Scripts/jquery.ui.position.js" type="text/javascript"></script>
        <script src="Scripts/jquery.ui.autocomplete.js" type="text/javascript"></script>
        <script src="Scripts/jquery.ui.combobox.js" type="text/javascript"></script> 

    tanto o autocompletar quanto o modal param de funcionar,para eu fazer o modal voltar a funcionar tenho que deixar como na 1a listagem de .js,ou se eu quiser deixar o autocompletar do DDL editável funcionado,tenho que deixar como na 2a listagem.Já procurei ajuda em vários lugares,ninguém ainda me ajudou a solucionar este problema,me sugeriram usar bootstrap...
    mas não quero ter que refazer, pelo menos não por agora,gosto de aprender com os erros.Quero entender o motivo deste conflito,acho que melhor que fugir do problema.

    Código caso queiram testar aí (com os.js da 2a listagem)-como não cabe aqui,postei no googledocs:

    https://docs.google.com/document/d/1BIorLTl7GfGCJAPlhXMjwPjBiUSEZ7Gl_o2ezbwSakk/

    desde já obrigado
    segunda-feira, 27 de janeiro de 2014 18:02