locked
Soma baseada em vário critérios RRS feed

  • Pergunta

  •  

    Olá Pessoal

    Estou tentando somar todos os registros:

    de um periodo que contenha a palavra "cargo"

                     a                  b      c

    10/01/2011 100    Cargo
    10/01/2011 100    Cargo
    15/01/2011 100    Emp
    05/02/2011 200    Emp  

    Tentei esta linha, mas nao estou conseguindo...

    =SE(C29:C32>="01/01/2011";SE(C29:C32<="31/01/2011";SE(E29:E32="Cargo";1;2);3);SOMA(D29:D32))

    Alguem teria alguma dica?

    Obrigado

     

    terça-feira, 15 de fevereiro de 2011 01:08

Todas as Respostas

  • Olá

    Verifique a possibilidade de usar a função SOMASES

     

    []'s


    David Brigido
    terça-feira, 15 de fevereiro de 2011 11:57
  •  

    Olá

    Já tentei, nao consegui com SOMASE

    Alguem tem alguma dica de preferencia com exemplo....

     

    Obrigado

    terça-feira, 15 de fevereiro de 2011 16:55
  • Jona de uma olhada em...

     

    http://www.officevb.com/2010/12/respondendo-perguntas-com-o-excel.html


    Teste ai e qqer coisa fale.

    Att


    Bruno Silva Leite
    officevb.com
    terça-feira, 15 de fevereiro de 2011 23:28
  •  

    Olá Colega

     

    Obrigado pelo link e atenção :-)

    Acho que estou no caminho certo.... mas tem algo que ainda nao estou conseguindo fazer...

     

    Quero que me retorne:

    o total do período informado do produto selecionado

    Por favor, o que esta errado na minha função ?

     

    =SOMARPRODUTO(--($B$8:$B$13>="01/01/2010"+0)*($B$8:$B$13<="07/01/2010"+0)*(E8:F13="Prego"))

    Ele retorna o valor 2 que é a qtde de produtos "prego" dentro do período que preciso, porem quero que retorne o "total"

    d1 d2 Destinatário (Nome) Total Produto
    06/01/2010 07/01/2010 Grupo Resgates 100 Prego
    06/01/2010 12/01/2010 Grupo Resgates 100  
    07/01/2010 08/01/2010 Grupo Portabilidade 200  
    07/01/2010 08/01/2010 Grupo Portabilidade 300 Prego
    28/01/2010 11/01/2010 Grupo Portabilidade 100 Prego
    08/01/2010 11/01/2010 Grupo Portabilidade 100 Prego

     

     

    quarta-feira, 16 de fevereiro de 2011 00:49
  •  

    Olá Pessoal

    Estou tentando somar todos os registros:

    de um periodo que contenha a palavra "cargo"

                     a                  b      c

     

    10/01/2011 100    Cargo
    10/01/2011 100    Cargo  
    15/01/2011 100    Emp  
    05/02/2011 200    Emp  

    Tentei esta linha, mas nao estou conseguindo...

    =SE(C29:C32>="01/01/2011";SE(C29:C32<="31/01/2011";SE(E29:E32="Cargo";1;2);3);SOMA(D29:D32))

    Alguem teria alguma dica?

    Obrigado

     

     

    =SOMASES(B1:B4;A1:A4;">="&40544;A1:A4;"<="&40574;C1:C4;"Cargo")


    quarta-feira, 16 de fevereiro de 2011 02:10
  •  

    Olá Colega

     

    Obrigado pelo link e atenção :-)

    Acho que estou no caminho certo.... mas tem algo que ainda nao estou conseguindo fazer...

     

    Quero que me retorne:

    o total do período informado do produto selecionado

    Por favor, o que esta errado na minha função ?

     

    =SOMARPRODUTO(--($B$8:$B$13>="01/01/2010"+0)*($B$8:$B$13<="07/01/2010"+0)*(E8:F13="Prego"))

    Ele retorna o valor 2 que é a qtde de produtos "prego" dentro do período que preciso, porem quero que retorne o "total"

     

    d1 d2 Destinatário (Nome) Total Produto
    06/01/2010 07/01/2010 Grupo Resgates 100 Prego
    06/01/2010 12/01/2010 Grupo Resgates 100  
    07/01/2010 08/01/2010 Grupo Portabilidade 200  
    07/01/2010 08/01/2010 Grupo Portabilidade 300 Prego
    28/01/2010 11/01/2010 Grupo Portabilidade 100 Prego
    08/01/2010 11/01/2010 Grupo Portabilidade 100 Prego

     

    =SOMASES(E8:E13;B8:B13;">="&40179;B8:B13;"<="&40185;F8:F13;"Prego")


    quarta-feira, 16 de fevereiro de 2011 02:20
  •  

    Olá Amigos,

    Obrigado pela atençao, fiz um exemplo ;-D

    Mandrix, obrigado pela dica ;-)

     

    4 B C D E F
    5
    6 Pregos Martelos
    7        TOTAL de PREGOS   TOTAL de MARTELOS 
    8 Data Qtde Produto  vendidos no PERÍODO vendidos no PERÍODO
    9 06/01/2011 100 Prego
    10 06/02/2011 100 Martelo 600 600      
    11 07/01/2011 500 Martelo
    12 07/01/2011 300 Prego 600        
    13 28/01/2011 100 Prego
    14 08/01/2011 100 Martelo
    15 15/02/2011 500 Martelo
    16 17/01/2011 100 Prego
     
             
      Na célula E10 digite: =SOMASES(C9:C16;B9:B16;">="&40544;B9:B16;"<="&40574;D9:D16;"Prego")
    Na célula F10 digite: =SOMASES(C9:C16;B9:B16;">="&40544;B9:B16;"<="&40574;D9:D16;"Martelo")
    outra maneira, abaixo:
     
       
     
       
      Na célula E12: =SOMARPRODUTO(($B$9:$B$16>=40544)*($B$9:$B$16<=40574)*($D$9:$D$16="Prego")*($C$9:$C$16))
    Digite o número 40544 e formate a célula com data, o resultado será 01/01/2011      
        40544 01/01/2011  >=  maior ou igual
    40574 31/01/2011  <= menor ou igual        
                     
                     

     

     

    quarta-feira, 16 de fevereiro de 2011 16:05