none
aplicação 2003 não roda no windows mobile 2005? RRS feed

  • Pergunta

  • Tenho uma aplicação mobile que foi desenvolvida com o VS 2003. Agora estou tentando instalar ela no Windows Mobile 2005, mas surge a seguinte mensagem de errro:

    Este aplicativo (xxxxx.exe) requer uma versão do Microsoft .Net Compact Framework mais recente do que a instalada neste dispositivo.

    Alguém sabe como resolver isto?

    quarta-feira, 7 de março de 2007 12:41

Todas as Respostas

  • Luis,

    Algumas opções (ainda sou novo no mundo mobile)...

    No device está instalado o .NET 2.0? Tente instalar o .NET 1.1. Ou faça o seguinte...
    O VS2003 usava o .NET 1.1. Sugiro, abrir o seu aplicativo em um VS2005 e compilar. Ele vai converter a aplicação. Eu já fiz algumas vezes, não tive problemas em converter não!

    Faça o deploy da aplicaçao para o device.

    E veja se funciona.

    [ ]'s

    sexta-feira, 9 de março de 2007 21:58
  • olá!

    Cara, também sou novo nessa parte de Mobile, mas assim, no meu caso tá acontecendo algo estranho. Meu visual studio já é o 2005 e o .NET é o 2.0. Até ai tudo bem, gerei o .exe do meu sistema, coloquei no palm e pediu a mesma mensagem, que precisa do .net mais recente, beleza, bora eu de atrás dessa joinha. Encontrei ele no site da microsoft, só que com extensão MSI de instalador, mas o meu ele só aceita .exe para executar a instalação, e agora, o que eu faço? hehehehe

    bom, isso é uma coisa, mas andei lendo, e descobri que o visual studio conecta e instala automaticamente essa nova versão estou certo?^pois bem, fiz isso e dai me dá essa mensagem:
    Error 1 The device security configuration disallowed the connection. Ensure that you have the appropriate certificates on your device for development. Review your SDK documentation for proper security settings for connecting to this device. Device Connectivity Component 

    e agora? quem poderá me defender? heheheheh

     

    Obrigado!

    quinta-feira, 15 de março de 2007 20:00
  • Companheiro,

    Bem... vamos começar ...  o seu POCKET (e não palm... CF roda no palm???)... ou pelo menos o emulador...

    Vc não consegue instalar nada no POCKET, tudo é instalado no PC que é transferido via um "conduit", o ActiveSync para o pocket.

    Recomendo vc atualizar o seu ActiveSync com a última versão para resolver o problema. Vc pode fazer o download dele no site da MS. Também recomendo tb a instalação do Windows Mobile 5. Se vc não fizer a diferença do SO de desenvolvimento.

    Espero ter ajudado.

    quinta-feira, 15 de março de 2007 22:39
  • Olá!

    tou lascado mesmo! heheheh

    Agradeço a tua resposta, mas eu sou muito burrinho ainda. Bom olha só o que eu fiz, atualizei o ActiveSync, normal, mas quando eu fui adicionar ou remover programas do palm, ele não apareceu nada, tentei sincronizar várias vezes, copiar em outras pastas o .msi mas nada.

    O que estou fazendo agora, baixando o framework 1.1 compact e vou tentar instalar no palm da mesma forma, tem alguma outra forma?

    E também estou baixando o framework 1.1 para o micro, vou tirar o 2.0 e instalar esse, vamos ver se assim funciona!

     

    Obrigado a todos.

    Fico no aguardo para mais alguma ajuda!

    terça-feira, 20 de março de 2007 19:41
  • Gente, esquece o tópico acima, fiz o deploy da aplicação e funcionou 100%!

    Obrigado a todos!

    Sucesso!

    terça-feira, 20 de março de 2007 20:07