none
Deploy com Visual Studio em Multi Server RRS feed

  • Pergunta

  • Senhores,

    Tenho meu Sharepoint Server 2010 dividido em alguns servidores: AD, SQL, Central Administration e Site, isso no servidor de Desenvolvimento.

    Estou tentando fazer um deploy pelo Visual Studio 2010 e ele da o seguinte erro:

    Error occurred in deployment step 'Activate Features': Feature with Id '80daf6ca-04c5-455c-a0f9-9603b550cac0' is not installed in this farm, and cannot be added to this scope.

    Penso eu que o erro ocorre devido essa divisão (servidores), porém gostaria de estar desenvolvendo desta forma mesmo.

    Alguém saberia me dizer como resolver este problema?

    Obrigado.


    Renan Patrick Carleto
    Analista desenvolvedor Sharepoint
    renancarleto.wordpress.com
    quinta-feira, 17 de março de 2011 19:27

Respostas

  • Larah, Renan

    Esse é o ambiente de desenvolvimento de vocês? Pra falar a verdade todo ambiente de desenvolvimento que vi foi um servidor (pode ser server farm) de SharePoint e nele instalado o Visual Studio, ter vários servidores assim é novidade. Normal seria ter o ambiente de homologação com vários servidores, mas então pega-se a solução gerada no Visual Studio e faz-se deploy nela como uma wsp normal

    Se esse for o ambiente de produção acho que não seria interessante ter o Visual Studio em nenhuma máquina. O ideal seria ter um servidor excluisvo para o Renan desenvolver suas aplicações (virtual no próprio computador). Ter mais de 1 pessoa desenvolvendo no mesmo servidor acaba gerando contratempos do tipo "vou reiniciar o IIS", "não reinicia agora que estou testando", e por aí vai.


    Atenciosamente,

    Fabian André Gehrke
    MCITP e MCPD SharePoint 2010
    http://fabiangehrke.com.br
    • Marcado como Resposta Renan PC sexta-feira, 8 de abril de 2011 16:23
    quinta-feira, 31 de março de 2011 23:37
    Moderador
  • Olá Larah e Renan, tudo bem?

    Como vocês estão utilizando um ambiente mais complexo para desenvolvimento, vale a pena verificar se o usuário com o qual vocês estão desenvolvendo/rodando o Visual Studio é um Farm Administrator.

    Me parece que o Visual Studio está escondendo algum erro antes. Muito provavelmente não está conseguindo subir uma versão atualizada do WSP.

     

    Abraços

     

    Rodrigo A. Romano
    -
    SharePoint Specialist
    Microsoft MCP e MCTS
    -

    http://rodrigoaromano.wordpress.com
    http://www.doneit.com.br

     


    Rodrigo A. Romano  


    Abraços Rodrigo A. Romano - SharePoint Specialist Microsoft MCP e MCTS - http://rodrigoaromano.wordpress.com
    • Marcado como Resposta Renan PC sexta-feira, 8 de abril de 2011 16:23
    sexta-feira, 8 de abril de 2011 02:36
    Moderador
  • Rodrigo e Fabian,

    Este ambiente na verdade foi um teste, seria interessante que funcionasse. Mas chegamos a uma conclusão que não irá funcionar e ficar gerando wsp atualizado todo momento não é o ideal.

    Então fechamos um ambiente de desenvolvimento em um único servidor.

    Obrigado pela ajuda dos dois.

     


    Renan Patrick Carleto
    Analista desenvolvedor Sharepoint
    renancarleto.wordpress.com
    • Marcado como Resposta Renan PC sexta-feira, 8 de abril de 2011 16:23
    sexta-feira, 8 de abril de 2011 16:23

Todas as Respostas

  • Renan,

    O Visual Studio está instalado no servidor do SharePoint? Se não, vc não vai conseguir fazer deploy pelo Visual Studio.

    Essa feature que está dando erro deve ser a sua feature, certo? Que tipo de solução ela é?


    Atenciosamente,

    Fabian André Gehrke
    MCITP e MCPD SharePoint 2010
    http://fabiangehrke.com.br
    sábado, 19 de março de 2011 14:56
    Moderador
  • Oi Fabian, tudo bom? hehe

    O que o Renan tentou explicar é que o seguinte:

    O ambiente que ele está montando é uma estrutura de 3 camadas. (obs, ele trabalha aqui comigo heheh)

    Server 01: AD

    Server 02: SQL

    Server 03: SharePoint (Host da Central de Administração + Serviços)

    Server 04: SharePoint Web

    O Visual Studio hoje está instalado no servidor de Web e ele não está conseguindo fazer o Deploy das soluções desta forma.


    Espero ter ajudado.
    Ajude manter o fórum organizado, se útil classifique!

    __________________________________________________________

    Larah Vidotti
    - MCTS > Sharepoint 2007 & 2010 Specialist
    - MCTS > Windows Server Virtualization
    - MCP > Windows server 2003
    - Blog
    - Twitter
    segunda-feira, 21 de março de 2011 18:03
  • Larah, Renan

    Esse é o ambiente de desenvolvimento de vocês? Pra falar a verdade todo ambiente de desenvolvimento que vi foi um servidor (pode ser server farm) de SharePoint e nele instalado o Visual Studio, ter vários servidores assim é novidade. Normal seria ter o ambiente de homologação com vários servidores, mas então pega-se a solução gerada no Visual Studio e faz-se deploy nela como uma wsp normal

    Se esse for o ambiente de produção acho que não seria interessante ter o Visual Studio em nenhuma máquina. O ideal seria ter um servidor excluisvo para o Renan desenvolver suas aplicações (virtual no próprio computador). Ter mais de 1 pessoa desenvolvendo no mesmo servidor acaba gerando contratempos do tipo "vou reiniciar o IIS", "não reinicia agora que estou testando", e por aí vai.


    Atenciosamente,

    Fabian André Gehrke
    MCITP e MCPD SharePoint 2010
    http://fabiangehrke.com.br
    • Marcado como Resposta Renan PC sexta-feira, 8 de abril de 2011 16:23
    quinta-feira, 31 de março de 2011 23:37
    Moderador
  • Olá Larah e Renan, tudo bem?

    Como vocês estão utilizando um ambiente mais complexo para desenvolvimento, vale a pena verificar se o usuário com o qual vocês estão desenvolvendo/rodando o Visual Studio é um Farm Administrator.

    Me parece que o Visual Studio está escondendo algum erro antes. Muito provavelmente não está conseguindo subir uma versão atualizada do WSP.

     

    Abraços

     

    Rodrigo A. Romano
    -
    SharePoint Specialist
    Microsoft MCP e MCTS
    -

    http://rodrigoaromano.wordpress.com
    http://www.doneit.com.br

     


    Rodrigo A. Romano  


    Abraços Rodrigo A. Romano - SharePoint Specialist Microsoft MCP e MCTS - http://rodrigoaromano.wordpress.com
    • Marcado como Resposta Renan PC sexta-feira, 8 de abril de 2011 16:23
    sexta-feira, 8 de abril de 2011 02:36
    Moderador
  • Rodrigo e Fabian,

    Este ambiente na verdade foi um teste, seria interessante que funcionasse. Mas chegamos a uma conclusão que não irá funcionar e ficar gerando wsp atualizado todo momento não é o ideal.

    Então fechamos um ambiente de desenvolvimento em um único servidor.

    Obrigado pela ajuda dos dois.

     


    Renan Patrick Carleto
    Analista desenvolvedor Sharepoint
    renancarleto.wordpress.com
    • Marcado como Resposta Renan PC sexta-feira, 8 de abril de 2011 16:23
    sexta-feira, 8 de abril de 2011 16:23