none
Aplicação sem acesso ao Banco de Dados após publicação no Azure RRS feed

  • Pergunta

  • Publiquei uma aplicação Asp.Net Core 2.1 no Azure, efetuei as Migrations, o banco e tabelas foram criadas normalmente, consigo ver toda a estrutura do banco pelo VS, mas a aplicação não acessa o banco.

    Alguém consegue me dizer o que pode estar acontecendo?

    Link da aplicação: https://grifo.azurewebsites.net/

    OBS: A mesma aplicação em ambiente de desenvolvimento acessa o banco local e funciona perfeitamente

    quinta-feira, 25 de outubro de 2018 02:33

Respostas

  • A solução foi simples. Apesar de subir os arquivos de configurações com a connectionString e as migrações, foi necessário efetuar uma update desse arquivos, via FTP (sem a publicação automática do VS) com a connectionString do servidor do Azure.
    terça-feira, 13 de novembro de 2018 21:03

Todas as Respostas

  • Boa tarde, UitanMaciel_. Tudo bem?

    Obrigado por usar o fórum MSDN.

    Você recebe alguma mensagem de erro ou algo do tipo?

    Atenciosamente,

    Filipe B de Castro

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    quinta-feira, 1 de novembro de 2018 19:19
    Moderador
  • A solução foi simples. Apesar de subir os arquivos de configurações com a connectionString e as migrações, foi necessário efetuar uma update desse arquivos, via FTP (sem a publicação automática do VS) com a connectionString do servidor do Azure.
    terça-feira, 13 de novembro de 2018 21:03