none
Problemas com Disign criado em WPF RRS feed

  • Pergunta

  • Fiz essa postagem na sessão C#, mas na verdade queria postar era aqui na sessão WPF, espero não ter nem um problema, pois todas as respostas serão bem vindas.!

    É o seguinte galera, tenho um projeto que venho trabalhando nele já faz um tempinho criando umas tela em WPF passei um bom tempo sem atualizar o Disign XAML somente mechendo no código dentro das classes, agora fui fazer uma modificação em alguns TextBlocks, Buttons e outros controles, mas quando executo o projeto em execução o controles continua da mesma forma, Ex.. Foregound="de Black para Red" ou adicionar um novo Button quando fasso a alteração na XAML tudo bem muda bonitinho, mas quando vou ver o TextBlock ou verificar o novo Button em tempo de execução  as alterações não são apresentadas, ou seja, Dising continua da mesma forma, isso está acontecendo para todos os controles não consigo mais mudar as telas do meu projeto!

    Alguém já se deparou com esse tipo de problema em WPF ..?

    Alguém tem alguma dica do que pode ser, configurações VS 2012 ou configurações nas propriedades do projeto ou o que será...?

    Atenciosamente

    André


    sexta-feira, 7 de junho de 2013 21:53

Respostas

  • <Style type={x:Type Textbox}>

    // Vai aplicar o estilo em todos os textbox que não tenham estilo configurado, deve estar dentro

    // do resource dictionary

    </Style>

    • Marcado como Resposta André Oliver quinta-feira, 13 de junho de 2013 01:14
    segunda-feira, 10 de junho de 2013 15:08

Todas as Respostas

  • Olá,

    Vc está usando algum template? styles? Algum resourcedictionary?

    Já verificou se vc está setando algum deles, ou até mesmo modificando diretamente as propriedades dos controles no code-behind?

    Cumpz, ADAE.

    sexta-feira, 7 de junho de 2013 22:17
  • AD_AE, sim estou utilizando template, style e resoucedictionary..!

    Mas já faz um bom tempo que utilizo eles e até então não tive problemas, mas até mesmo com controles padrões sem especificar style para o mesmo o problema acontece..!

    O duvidoso é que quando estou adicionando os controles no XAML é apresentando no mesmo instante, mas quando executo o programa quando vou ver a tela o controle não está lá no local posicionado..!

    OBS.:

    O que detectei é que ele não está conseguindo instanciar os controles.!

    Ex.: Criei um novo Button e dei o nome de x:Name="btnNovo" e na construtor por trás do código, fiz o seguinte

            public MyWpf
            {
                InitializeComponent();
                btnNovo.Visible = true;
            }

    e vi que o btnNovo está NULL, ou seja, quer dizer que mesmo depois de InitizalizeComponent o btnNovo deveria ser instanciado tbm.. mas não estar..!

    Obs.: Isso tudo está acontecendo no computador da Empresa, mas na minha casa com o mesmo projeto, mas em computador diferente e instalação VS 2012 está funcionando perfeitamente, então suponho que seja alguma configuração alterada no VS 2012 da maquina em siii, mas não tenho a menor ideia do que seja..!

    Atenciosamente

    André


    sexta-feira, 7 de junho de 2013 22:23
  • <Style type={x:Type Textbox}>

    // Vai aplicar o estilo em todos os textbox que não tenham estilo configurado, deve estar dentro

    // do resource dictionary

    </Style>

    • Marcado como Resposta André Oliver quinta-feira, 13 de junho de 2013 01:14
    segunda-feira, 10 de junho de 2013 15:08