locked
Problema nos cálculos com função SE no excel - Macro pode resolver RRS feed

  • Pergunta

  • Ola Pessoal!

    Amigos estou com um grande problema!

    Eu tenho uma fórmula na minha planilha com várias condicionais SE, e para isso eu usei o & para fazer os varios SE's. Do resultado verdadeiro desta condicional, a fórmula faz um cálculo de divisão que, não sei por qual motivo está dando errado... o n° do resultado está ficando com mais de uma virgula explo: 24,561,233 e tentei configurar a célula mas o excel não aceita a configuração. Porque será? Será que é pelo uso excessivo de SE's?

    Teria uma macro para substituir a função SE com muito critérios?

    Segue fórmula:

    =SE($G20="2085372CX";AB20/J20;SE($G20="2085813CX";AB20/J20;SE($G20="2127515CX";AB20/J20;SE($G20="2085182CX";AB20/J20;SE($G20="2085352CX";AB20/J20;SE($G20="2124796CX";AB20/J20;SE($G20="2149379CX";AB20/J20;"")))))))&SE($C20="CAFES";$AB20;SE($C20="FILTROS";$AB20*$K20;SE($C20="CAPPUCCINO"; $AB20/$K20;SE($C20="CAFECOMLEITE";$AB20/$K20;SE($C20="SOLUVEIS";$AB20/$K20;SE($C20="REFRESCO";$AB20/$K20;""))))))

    Obrigado.

    domingo, 2 de maio de 2010 14:44

Respostas

  • Boa noite,

    Com certeza o seu problema de formatação não pode ser atribuído à questão da fórmula utilizada.

    Aparentemente o seu problema com as vírgulas deve-se ao fato delas estarem estabelecidas como separadoras de decimais.

    Montei esta versão mais curta da fórmula:

    =SE(OU($G20="2085372CX";$G20="2085813CX";$G20="2127515CX";$G20="2085182CX";$G20="2085352CX";

    $G20="2124796CX";$G20="2149379CX");AB20/J20;"")&SE($C20="CAFES";$AB20;SE($C20="FILTROS";$AB20*$K20;

    SE(OU($C20="CAPPUCCINO"; $C20="CAFECOMLEITE";$C20="SOLUVEIS";$C20="REFRESCO");$AB20/$K20;"")))

    [ ]s


    Adilson Soledade - MOS http://adilsonsoledade.blogspot.com/
    • Marcado como Resposta diogoska terça-feira, 4 de maio de 2010 23:27
    segunda-feira, 3 de maio de 2010 02:28

Todas as Respostas

  • Boa noite,

    Com certeza o seu problema de formatação não pode ser atribuído à questão da fórmula utilizada.

    Aparentemente o seu problema com as vírgulas deve-se ao fato delas estarem estabelecidas como separadoras de decimais.

    Montei esta versão mais curta da fórmula:

    =SE(OU($G20="2085372CX";$G20="2085813CX";$G20="2127515CX";$G20="2085182CX";$G20="2085352CX";

    $G20="2124796CX";$G20="2149379CX");AB20/J20;"")&SE($C20="CAFES";$AB20;SE($C20="FILTROS";$AB20*$K20;

    SE(OU($C20="CAPPUCCINO"; $C20="CAFECOMLEITE";$C20="SOLUVEIS";$C20="REFRESCO");$AB20/$K20;"")))

    [ ]s


    Adilson Soledade - MOS http://adilsonsoledade.blogspot.com/
    • Marcado como Resposta diogoska terça-feira, 4 de maio de 2010 23:27
    segunda-feira, 3 de maio de 2010 02:28
  • Adilson como sempre me socorrendo!

    Amigo vou testar esta fórmula menor, mas é muito estranho o que está acontecendo... já chequei tudo milhares de vezes e não entendo esse erro...

    Depois te dou retorno,

     

    terça-feira, 4 de maio de 2010 01:12
  • Teste e deu certo!!!

    Obrigado mais uam vez, acho que fórmula estava muito grande, quando tirei o concatenar & entre as fórmulas o cálculo deu certo.

    Fica aqui a experiência para outros.

    terça-feira, 4 de maio de 2010 23:29