none
Validação de dados no Excel sem dados repetidos? RRS feed

  • Pergunta

  • Preciso criar uma validação de dados sem os repetidos.
    Lista original

    a
    a
    b
    b
    c
    c

    Validação

    a
    b
    c

    Só para acrescentar na planilha que estou desenvolvendo a lista original altera os dados de acordo com o filtro avançado + macro que apliquei, acredito que deverá utilizar a função DESLOC.

    domingo, 29 de junho de 2014 01:04

Todas as Respostas

  • Olá Nivaldo!

    Você pode utilizar uma gravação simples de macro utilizando o recurso de "Remover Duplicatas" da aba "Dados". O código ficará mais ou menos assim:

    Sub RemoverDuplicatas()
    
        Sheets("Plan1").Select
        Columns("A:A").Select
        Selection.Copy
        Sheets("Plan2").Select
        ActiveSheet.Paste
        Application.CutCopyMode = False
        ActiveSheet.Range("$A:$A").RemoveDuplicates Columns:=1, Header:=xlYes
        Range("A1").Select
        
    End Sub

    Onde Plan1 é sua planilha de origem e Plan2 o destino. E A:A é a coluna que será copiada para a planilha de destino para ter os valores duplicados removidos.

    Se quiser deixar algo dinâmico, você pode adaptar um fórmula matricial do Excel. Observe a imagem e a fórmula e adapte a sua necessidade. Não sei se essa fórmula é a mais eficiente para esta situação, mas funciona e foi a primeira ideia que me veio a mente agora. Se eu pensar numa forma mais simplificada eu posto posteriormente.

    A fórmula utilizada acima é:

    =SEERRO(PROC(MÍNIMO(SE(CONT.SE($D$1:D1;$A$2:$A$20)>0;"";LIN($A$2:$A$20)));SE(CONT.SE($D$1:D1;$A$2:$A$20)>0;"";LIN($A$2:$A$20));$A$2:$A$20);"")

    Abraços!


    Rafael Kamimura


    segunda-feira, 30 de junho de 2014 14:03