none
Mencionar descontos selecionados RRS feed

  • Pergunta

  • Pessoal, tenho um problema que é o seguinte: existem 3 descontos nas células A1 até A3 ("desconto A", "desconto B" e "desconto C") em uma planilha, e na coluna B indica quais descontos foram selecionados. Gostaria de em uma outra célula indicar um texto dizendo quais são os descontos selecionados (na célula B5), indicando com vírgulas caso haja mais de um desconto selecionado. Segue o exemplo na imagem:

    Como posso fazer isso (pode ser por fórmula ou por VBA mesmo). Obrigado!!!


    • Editado dmfmakko segunda-feira, 24 de novembro de 2014 11:14 correção
    segunda-feira, 24 de novembro de 2014 11:07

Respostas

  • Uma sugestão de fórmula na célula B5 baseado no seu modelo:

    =SE(CONT.SE(C1:C3;VERDADEIRO)=0;"Nenhum desconto selecionado!!!";SUBSTITUIR("Os descontos selecionados são: "&SE(C1=VERDADEIRO;"Desconto A, ";"")&SE(C2=VERDADEIRO;"Desconto B, ";"")&SE(C3=VERDADEIRO;"Desconto C, ";"")&" ";",  ";"!!!"))

    ou

    =SE(CONT.SE(C1:C3;VERDADEIRO)=0;"Nenhum desconto selecionado!!!";SUBSTITUIR(SE(CONT.SE(C1:C3;VERDADEIRO)=1;"O desconto selecionado é o ";"Os descontos selecionados são: ")&SE(C1=VERDADEIRO;"Desconto A, ";"")&SE(C2=VERDADEIRO;"Desconto B, ";"")&SE(C3=VERDADEIRO;"Desconto C, ";"")&" ";",  ";"!!!"))


    Rafael Kamimura


    • Editado Rafael Kamimura segunda-feira, 24 de novembro de 2014 12:15
    • Marcado como Resposta dmfmakko segunda-feira, 24 de novembro de 2014 13:36
    segunda-feira, 24 de novembro de 2014 11:59