none
Falha no schema XML org.xml.sax.SAXParseException: cvc-pattern-valid: Value '1.10' is not facet-valid with respect to pattern '2\.00' RRS feed

  • Pergunta

  • Estou com problemas para autorizar NF-e 2.00, consigo enviar os lotes tranquilamente porem ao consultar o relatorio do envio recebo:

    "<tpAmb xmlns="http://www.portalfiscal.inf.br/nfe">2</tpAmb><verAplic xmlns="http://www.portalfiscal.inf.br/nfe">PR-v2_1_13</verAplic><cStat xmlns="http://www.portalfiscal.inf.br/nfe">215</cStat><xMotivo xmlns="http://www.portalfiscal.inf.br/nfe">Falha no schema XML. org.xml.sax.SAXParseException: cvc-pattern-valid: Value '1.10' is not facet-valid with respect to pattern '2\.00' for type 'TVerNFe'.</xMotivo><cUF xmlns="http://www.portalfiscal.inf.br/nfe">41</cUF>"

     

    Alguem tem ideia do que pode ser? creio que meu xml está correto.

    <?xml version="1.0" encoding="UTF-8"?>
    <enviNFe xmlns="http://www.portalfiscal.inf.br/nfe" versao="2.00">
     <idLote>000000000000004</idLote>
    <NFe xmlns="http://www.portalfiscal.inf.br/nfe">
    .
    .
    .
    </NFe>  
    </enviNFe>
    

    terça-feira, 22 de março de 2011 20:16

Respostas

  • Achei a falha!!! como estou atualizando o emissor 1.10 para o 2.00 acabei nao fazendo o ajuste no xml de dados do RetRecepçao lote.. O correto é.:

     

    "<?xml version=\"1.0\" encoding=\"UTF-8\"?><consReciNFe xmlns=\"http://www.portalfiscal.inf.br/nfe\" versao=\"", Configuracao.VersaoDados, "\"><tpAmb>", Configuracao.tpAmb, "</tpAmb><nRec>", NumReciboLote, "</nRec></consReciNFe>"
    

     

    (Y)

    • Marcado como Resposta Maicon Cesar Vaz quinta-feira, 24 de março de 2011 18:19
    quinta-feira, 24 de março de 2011 18:19