none
Data Source RRS feed

  • Pergunta

  • ola galera toh tendo problemas na hora de criar o data souce no visual estudio, alguem jah teve esse problema? tipow... eu clico em new data souce soh dai naum apare servidor nenhum... tipow... visual studio mais windows vista, tem problemas de compatibilidade? aguardo resposta
    domingo, 24 de junho de 2007 01:25

Respostas

  • Oi !

     

    No windows vista você deve rodar o visual studio como administrador, clicando com o botão direito e utilizando run as administrator.

     

    Além disso, existe um service pack especial do visual studio para ele ser rodado no windows vista.

     

    Fora isso, utilizo este conjunto normalmente.

     

    []'s

     

    domingo, 24 de junho de 2007 02:45
  • Oi !

     

    Vou dar algumas indicações para fazer isso funcionar, mas para colocar isso em produção você vai precisar de mais auxilio de alguém de infraestrutura....

     

    1) Troque o sql server para modo misto

     

    2) Reinicie o serviço do sql server

     

    3) Em logins, localize o login SA

     

    4) Atribua uma senha ao login SA

     

    5) No item status (na janela de propriedades do login) mude o status do login SA para Enabled

     

    6) No visual studio, ao criar um datasource, clique em new connection. Ele vai perguntar se a conexão é windows ou sql, utilize sql e o login SA com a senha que você criou. Selecione na combo abaixo o banco de dados ao qual vai se conectar.

     

    Pronto, vai funcionar, mas definitivamente não é a melhor forma de fazer para o ambiente de produção, quando a aplicação estiver pronta.

     

    []'s

     

    segunda-feira, 25 de junho de 2007 03:42

Todas as Respostas

  • Oi !

     

    No windows vista você deve rodar o visual studio como administrador, clicando com o botão direito e utilizando run as administrator.

     

    Além disso, existe um service pack especial do visual studio para ele ser rodado no windows vista.

     

    Fora isso, utilizo este conjunto normalmente.

     

    []'s

     

    domingo, 24 de junho de 2007 02:45
  • ok fera vlws pela ajuda

    t+

    domingo, 24 de junho de 2007 03:37
  • fera tentei aki e naum deu certo.... tipow.... naum consegue achar a server... ou entaum acesso negado.... ainda naum coloquei o sp 1 for vista, seria esse o problem?
    domingo, 24 de junho de 2007 06:49
  • Oi !

     

    1) Qual o server, standard ou express ?

     

    2) Se é o express, você instalou o management studio express ?

     

    3) Em qualquer dos casos, pelo management studio express você conecta ? Com usuário do SQL ou com Windows Authentication ?

     

    4) O SQL Server está em modo misto ou windows ?

     

    5) Qual modo de autenticação você está tentando pelo VS, standard ou integrado ?

     

    6) Está usando SA como usuário ?

     

    7) Se sim, ele está habilitado ?

     

    []'s

     

     

    domingo, 24 de junho de 2007 18:47
  • respostas

    1) Qual o server, standard ou express ?

     kra naum sei direito mais acho que o enterprise, baixei uma vesrsão trial



     

    3) Em qualquer dos casos, pelo management studio express você conecta ? Com usuário do SQL ou com Windows Authentication ?


    windows authentication

     

    4) O SQL Server está em modo misto ou windows ?

     windows


    5) Qual modo de autenticação você está tentando pelo VS, standard ou integrado ?

    kra naum sei... com faco pra verificar isso?

     

    6) Está usando SA como usuário ?

    naum sei tbém... tipow... quando clico pra entrar... naum pede usuario nenhum... tipow... acho q eh o user do win mesmo....

     

    7) Se sim, ele está habilitado ?

    como faco pra habilitar....



    aguardo resposta.... mesmo assim vlws.... mais tipow... se até amanha naum der certo vo ter q por o xp e fazer o trab... pq toh tendo mtos problemas por causa do vista e tenho q terminar em 2 semanas.... vlws


    segunda-feira, 25 de junho de 2007 03:00
  • Oi !

     

    Vou dar algumas indicações para fazer isso funcionar, mas para colocar isso em produção você vai precisar de mais auxilio de alguém de infraestrutura....

     

    1) Troque o sql server para modo misto

     

    2) Reinicie o serviço do sql server

     

    3) Em logins, localize o login SA

     

    4) Atribua uma senha ao login SA

     

    5) No item status (na janela de propriedades do login) mude o status do login SA para Enabled

     

    6) No visual studio, ao criar um datasource, clique em new connection. Ele vai perguntar se a conexão é windows ou sql, utilize sql e o login SA com a senha que você criou. Selecione na combo abaixo o banco de dados ao qual vai se conectar.

     

    Pronto, vai funcionar, mas definitivamente não é a melhor forma de fazer para o ambiente de produção, quando a aplicação estiver pronta.

     

    []'s

     

    segunda-feira, 25 de junho de 2007 03:42
  • ok, consegui aki de uma outra forma... obrigado pela ajuda... a duvida agora eh outra, vou postar em um novo topico
    segunda-feira, 25 de junho de 2007 05:22