none
CRM 2011 - envio de email via workflow RRS feed

  • Pergunta

  • Olá a todos.

    Fiz um workflow para envio de email com disparo automático, conforme for a opção de um campo pick list.

    O status do workflow sempre fica como “waiting” e o processo apresenta a mensagem de erro “Você não pode enviar email como o usuário selecionado. o usuário selecionado não tem permissão para isso ou você não tem privilégios suficientes. contate o administrador do sistema para obter ajuda.”

    Já testei o envio de email manual e o controle de acessos. Tudo está aparentemente correto, da forma como funcionava até recentemente.

    Alguém sabe o que pode estar ocorrendo e como resolver, por favor?

    Grato.
    João Luiz
    terça-feira, 23 de agosto de 2011 21:12

Todas as Respostas

  • Já olhou os serviços de processameto assíncrono e e-mail router (se utiliza)?

    Outra coisa que pode ser é o usuário que está executando o fluxo não tiver permissões suficientes para realizar o envio de um e-mail, como: não pode criar uma atividade, não poder enviar e-mail usando o e-mail de outro usuário (caso aplique-se), etc...

    Pelo que disse se você deixar o seu perfil igual ao do usuário que está tentando executar o fluxo, abrir uma atividade de e-mail e enviar funciona corretamente?

    Eu estou apostando em um problemas nos serviços!

     

    Att,


    Tiago Michelini Cardoso MCTS - MCC
    https://tiagomcardoso.wordpress.com/
    quarta-feira, 24 de agosto de 2011 16:42
    Moderador
  • Tiago, obrigado pelo retorno.

    Os serviços estão ok.

    Com o usuário administrador, o workflow funciona. Peguei outro usuário como exemplo, igualei a BU e o direito de acesso ao do Admin e o erro continua.

    Pode ser configuração do router ou restrição de usuários em alguma outra configuração, AD por exemplo?

    Grato.

     


    João Luiz
    quarta-feira, 24 de agosto de 2011 19:47
  • Veja como está configurado a saída dos e-mails no cadastro dos usuários, depois veja como está configurado o e-mail router para o admin versus de um usuário qualquer, provavelmente existem duas configurações diferentes...


    Tiago Michelini Cardoso MCTS - MCC
    https://tiagomcardoso.wordpress.com/
    quinta-feira, 25 de agosto de 2011 12:19
    Moderador
  • João bom dia. Conseguiu resolver a questão?

    Atenciosamente,
    Rodrigo Hentz - MCP.MCPS.MCNPS.MCTS.MBSS.MBSP.MCITP
    Profile
    Blog

    quarta-feira, 13 de fevereiro de 2013 10:52
    Moderador
  • Olá,

    Existe uma outra configuração que pode ser vista como necessária dependendo de quem envia o email do WF. No caso, se o "FROM" do WF não for o usuário logado é necessário realizar a seguinte configuração:

    1 - Logar no CRM com o usuário que irá constar no campo "FROM" do email;

    2 - Navegar até a aba EMAIL nas configurações pessoais deste usuário (Arquivo > Opções > Email);

    3 - Marcar a opção: "Permitir que outros usuários do Microsoft Dynamics CRM enviem emails em meu nome."

    IMPORTANTE: esta opção possibilita qualquer outro usuário enviar email manualmente em nome de um segundo usuário que possui esta opção marcada, caso outras configurações (como perfil de acesso) assim permitam.

    Espero que ajude.

    Abraços


    Dandroni

    quarta-feira, 13 de fevereiro de 2013 17:44
  • Verifique se o Email do usuário está aprovado no seu cadastro.

    Tiago Henrique Consultor de Implantação

    terça-feira, 26 de fevereiro de 2013 17:37
  • Tente simular o envio do e-mail manualmente, para o mesmo endereço, com o mesmo usuário que está executando o Workflow. Se não conseguir, não é problema do Workflow e sim de Direitos de Acesso ou do E-mail Router.
    quinta-feira, 24 de outubro de 2013 16:57
  • João,

    Na maquina do usuário eu fui em "Arquivo, Opções" e em seguida fui na aba (Email) e selecionei o campo "Permitir que outros usuário do Microsoft Dynamics CRM enviem emails em seu nome" e funcionou perfeitamente.

    font: http://social.msdn.microsoft.com/Forums/pt-BR/c1f91041-81c8-47bb-a90e-68c0fb07c941/crm-2011-usurio-sem-privilgios-para-enviar-email?forum=dynamicscrmpt


    Tiago Henrique Consultor de Implantação

    quinta-feira, 5 de dezembro de 2013 11:06