none
Workflow usando acesso externo. RRS feed

  • Pergunta

  • Olá Pessoal,

    Eu tenho uma intranet e recentemente liberei um acesso externo aos meus promotores de venda com o intuito de aproxima-los da minha organização.

    Tenho um espaço de trabalho onde internamente, quando os usuários criam, dispara um e-mail informando esse agendamento.

    Quando o acesso é externo, o workflow não funciona.

    Será que alguém já passou por esse problema ou tem alguma ideia de como me auxiliar.

    Um abraço a todos.

    Luiz Branco

    Londrina - PR

    quarta-feira, 10 de outubro de 2012 12:15

Respostas

  • Resolvi.

    Criei um mapeamento alternativo dento do Sharepoint e funcionou.

    Se alguem tiver esse problema, favor me avisar.

    Obrigado a todos que me auxiliaram.

    Grande Abraço.

    • Marcado como Resposta Luiz G. Branco quarta-feira, 17 de outubro de 2012 14:15
    quarta-feira, 17 de outubro de 2012 14:15

Todas as Respostas

  • Luiz,

    O acesso externo, você está utilizando qual autenticação? Forms ou Acesso Anônimo?


    Atenciosamente, Rafael Fausto

    quarta-feira, 10 de outubro de 2012 17:14
  • Luiz,

    Por acesso externo você está dizendo usuários de fora da sua empresa que possuem login ou eles acessam o site sem precisar de autenticação, como se fosse um site normal da internet?


    Atenciosamente,

    Fabian André Gehrke
    MCITP e MCPD SharePoint 2010
    http://fabiangehrke.com.br

    quinta-feira, 11 de outubro de 2012 12:55
    Moderador
  • Olá pessoal.

    Desculpe a demora para responder, mas seguem as respostas para os Srs. Rafael e Fabian.

    Estou usando autenticação com o meu AD, ou seja, os meus colaboradores externos conectam no meu portal em Sharepoint digitam usuário e senha, e quando executam o agendamento, o e-mail não é enviado.

    Quando o acesso é dentro da minha rede interna (com o mesmo usuário), assim que o agendamento é feito o e-mail é enviado.

    Desde já eu agraço o apoio de vocês.

    Abraços.

    Luiz Branco,

    • Marcado como Resposta Luiz G. Branco terça-feira, 16 de outubro de 2012 19:03
    • Não Marcado como Resposta Luiz G. Branco terça-feira, 16 de outubro de 2012 19:28
    terça-feira, 16 de outubro de 2012 19:02
  • Luiz,

    Como você resolveu?


    Atenciosamente, Rafael Fausto

    terça-feira, 16 de outubro de 2012 19:20
  • Rafael,

    Na verdade não foi resolvido não, eu havia marcado como resolvido.

    Se possível, eu gostaria do apoio de vocês, pois será muito importante para mim.

    Atenciosamente, Luiz Branco.

    terça-feira, 16 de outubro de 2012 19:29
  • Luiz,

    Quando você diz: "Tenho um espaço de trabalho onde internamente, quando os usuários criam, dispara um e-mail informando esse agendamento."

    Esse disparo de e-mail é um alerta que você configurou na biblioteca/lista ou um workflow que você criou pelo SharePoint Designer?

    Você já deu uma olhada nos logs?


    Atenciosamente, Rafael Fausto

    terça-feira, 16 de outubro de 2012 19:51
  • Olá pessoal.

    Desculpe a demora para responder, mas seguem as respostas para os Srs. Rafael e Fabian.

    Estou usando autenticação com o meu AD, ou seja, os meus colaboradores externos conectam no meu portal em Sharepoint digitam usuário e senha, e quando executam o agendamento, o e-mail não é enviado.

    Quando o acesso é dentro da minha rede interna (com o mesmo usuário), assim que o agendamento é feito o e-mail é enviado.

    Desde já eu agraço o apoio de vocês.

    Abraços.

    Luiz Branco,

    Possivelmente seu servidor de e-mail não está fazendo relay.

    Como foi configurado esse workflow? Você utiliza Exchange? Seu servidor smtp faz relay para um servidor externo?

    Sem algumas informações fica dificil saber.

    Abraço


    ROBERTOSLJUNIOR

    terça-feira, 16 de outubro de 2012 20:14
  • Luiz,

    Você está dizendo que ao acessar com o mesmo usuário de dentro da rede e de fora o comportamento é diferente? Aí teria que saber como as coisas estão configuradas, pq é um cenário um pouco estranho, geralmente as coisas funcionam para um usuário e não para outro.

    Mande mais detalhes do seu ambiente, por favor, como como está configurado o email, aonde fica o servidor, etcs.


    Atenciosamente,

    Fabian André Gehrke
    MCITP e MCPD SharePoint 2010
    http://fabiangehrke.com.br

    quarta-feira, 17 de outubro de 2012 00:23
    Moderador
  • Olá Pessoal,

    Roberto,

    Os alertas foram configurados através do Sharepoint Designer.

    Eu atualmente não utilizo o Exchange. Utilizo um smtp interno que faz relay para um serviço de e-mail da locaweb (externo).

    Creio que o problema esteja nesse meu smtp.

    Fabian,

    Então....a questão é essa, o acesso funciona normal (tanto rede interna como externa), mas o que não funciona é o alerta.

    Qual seria uma saída mais fácil para resolver essa questão do e-mail uma vez que o Sharepoint 3.0 não tem a opção de autenticação.

    Abraços e mais uma vez muito Obrigado pela proatividade de vocês.

    Luiz Branco

    quarta-feira, 17 de outubro de 2012 11:59
  • Para começar, acho uma boa olhar os logs (SharePoint e servidor SMTP).

    Você já leu esse documento sobre como configurar o servidor smtp do IIS?
    http://office.microsoft.com/en-us/windows-sharepoint-services-it/configuring-e-mail-settings-HA001160793.aspx


    Atenciosamente, Rafael Fausto


    • Editado Rafael Fausto quarta-feira, 17 de outubro de 2012 12:32 adicionando mais conteúdo.
    quarta-feira, 17 de outubro de 2012 12:22
  • Olá Rafael,

    Na época que eu configurei, eu usei justamente esse link como referência.

    Bom....de qualquer maneira eu acabei de conferir e está tudo de acordo.

    ABraços.

    quarta-feira, 17 de outubro de 2012 12:43
  • E os logs?

    Pode aparecer algo também no event viewer. Já verificou?


    Atenciosamente, Rafael Fausto

    quarta-feira, 17 de outubro de 2012 12:56
  • Rafael,

    No Event viewer não está gerando nada.

    No log do SMTP, gera apenas quando o e-mail é enviado, ou seja, quando é dentro da rede interna.

    Muito estranho.

    quarta-feira, 17 de outubro de 2012 13:24
  • Você poderia fazer um teste, enviar um e-mail para um destinatario externo utilizando o telnet.

    Como no exemplo desse site
    http://www.brunocunha.com/blog/profissional/enviar-e-mail-com-telnet/

    Pode fazer?


    Atenciosamente, Rafael Fausto

    quarta-feira, 17 de outubro de 2012 13:40
  • Rafael,

    Enviado normal.

    Seguinte.. achei o seguinte erro no servidor do sharepoint.

    O que acontece é o seguinte.....quando eu instalei, o meu portal era para ser apenas um portal interno.

    Eu instalei informando apenas o hostname interno Ex: terra

    E agora eu liberei o acesso externo criando um DNS no servidor web Ex: portal.zzzzzz.com.br

    Veja o erro:

    Event ID 6875

    Error loading and running event receiver Microsoft.SharePoint.Workflow.SPWorkflowAutostartEventReceiver in Microsoft.SharePoint, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c. Additional information is below.

    : O aplicativo Web em http://portal.zzzzzz.com.br/agenda não pôde ser encontrado. Verifique se você digitou a URL corretamente. Se a URL deveria apresentar o conteúdo existente, o administrador do sistema talvez precise adicionar um novo mapeamento da URL solicitada para o aplicativo desejado.

    quarta-feira, 17 de outubro de 2012 13:54
  • Resolvi.

    Criei um mapeamento alternativo dento do Sharepoint e funcionou.

    Se alguem tiver esse problema, favor me avisar.

    Obrigado a todos que me auxiliaram.

    Grande Abraço.

    • Marcado como Resposta Luiz G. Branco quarta-feira, 17 de outubro de 2012 14:15
    quarta-feira, 17 de outubro de 2012 14:15
  • Show de bola!

    Atenciosamente, Rafael Fausto

    quarta-feira, 17 de outubro de 2012 14:21
  • Luiz,

    Muito bom, parabéns.

    É importante deixar claro que todos os endereços que forem utilizados para acessar o SharePoint devem estar mapeados no mapeamento alternativo de acesso. Caso contrários alguns problemas, como esse e outros, podem acontecer.


    Atenciosamente,

    Fabian André Gehrke
    MCITP e MCPD SharePoint 2010
    http://fabiangehrke.com.br

    quarta-feira, 17 de outubro de 2012 15:17
    Moderador