none
Não consigo fazer chamada do Bootstrap no VS 2013 RRS feed

  • Pergunta

  • O código abaixo não funciona no VS 2013, mas funciona perfeitamente bem no Aptana.

    A única diferença é o editor, logo a chamada do Bootstrap não está certa.

    Por favor, quando eu estiver desenvolvendo, será no visual studio e não no Aptana, logo preciso saber o que está errado e como corrigir o erro.

    <!DOCTYPE html>
    <html xmlns="http://www.w3.org/1999/xhtml">
    <head>
        <meta charset="utf-8" />
        <title>Meu Primeiro Projeto com Bootstrap</title>
        <link href="Content/bootstrap.css" rel="stylesheet" />
        
        <!-- Latest compiled and minified CSS -->
        <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/css/bootstrap.min.css">
        <!-- Optional theme -->
        <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/css/bootstrap-theme.min.css">
        <!-- Latest compiled and minified JavaScript -->
        <script src="https://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/js/bootstrap.min.js"></script>
    
    
    </head>
    <body>
        <div class="container">
            <div class="row" id="topo">
                <div class="span5"><h1>Logo do Projeto</h1></div>
                <div class="span7">
                    <form class="form-search">
                        <input type="text" class="input-medium search-query" />
                        <button class="btn" type="submit">Busca</button>
                    </form>
                </div>
            </div>
    
            <div class="row" id="corpo">
                <div class="span4">
                    <ul>
                        <li><a href="#">Inicial</a></li>
                        <li><a href="#">Quem Somos</a></li>
                        <li><a href="#">Serviços</a></li>
                        <li><a href="#">Fale Conosco</a></li>
    
                    </ul>
                </div>
                <div class="span8">
                    <h1>Olá mundo!</h1>
                    <p>texto simples....</p>
                </div>
            </div>
            <div class="row" id="rodape">
                <div class="span12">Rodapé</div>
            </div>
        </div>
    </body>
    </html>
    

    Galeano

    segunda-feira, 22 de setembro de 2014 22:23

Respostas

  • Cara o VS2013 não tem nada contra o bootstrap, inclusive se vc starta um projeto o template que vem é o bootstrap!

    Vc removeu uma das referencias ao CSS? Deixa somente a do CDN, abaixo:

    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/css/bootstrap.min.css">



    Blog Breno Queiroz – MCP


    • Editado Breno Queiroz terça-feira, 23 de setembro de 2014 20:02
    • Marcado como Resposta Galeano 2014 terça-feira, 23 de setembro de 2014 20:14
    terça-feira, 23 de setembro de 2014 20:02

Todas as Respostas

  • Adiciona o bootstrap pelo nuget é mais prático e qualquer atualização é feita automaticamente.

    Abre a solução e vai em tools/library package manager/manage nuget packages for solution e na pesquisa coloca bootstrap, ele adiciona tudo automaticamente.


    Junior

    terça-feira, 23 de setembro de 2014 11:17
  • Oi Junior, muito obrigado pela sua resposta.

    Fiz o que você indicou, mas ainda não consegui obter o resultado esperado.

    Com imagens ficará mais fácil: Esse é o resultado que tenho que obter (aqui é no Aptana) (Olá mundo recuado)

    Esse é o resultado que estou obtendo: (aqui é no VS 2013)

    Você tem 8.267 pontos e parou justamente aqui na minha dúvida. Por favor, tem que ser um problema débil.

    Forte abraço

    terça-feira, 23 de setembro de 2014 14:27
  • Estou dividindo a máquina com o Fábio, ele estava logado e eu nem vi!

    Mas fica aí mesmo a dúvida!

    Galeano

    terça-feira, 23 de setembro de 2014 14:31
  • Veja se ele está fazendo a referencia ao css correto. Ou se tem mais tem um CSS

    Junior

    terça-feira, 23 de setembro de 2014 18:50
  • // BOOTSTRAP CSS
    <link href="Content/bootstrap.css" rel="stylesheet" />
        
    // BOOTSTRAP CSS DENOVO ?????
    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/css/bootstrap.min.css">
    Use somente um dos CSS.

    Blog Breno Queiroz – MCP

    terça-feira, 23 de setembro de 2014 19:05
  • Oi Breno, sei que estou irritante, mas mais irritante que eu está o problema.

    As imagens que printei de manhã mostram exatamente a bagaça!

    Quando vi que não tava acertando de jeito nem um, passei o código para o Aptana e rodou que foi uma beleza!

    Logo, conclui que só pode ser a chamada no VS 2013.

    O VS não tá nem aí para o bootstrap, inclusive leva a uma outra pergunta que fiz aqui no fórum: o intelisense não tomou conhecimento do Bootstrap, isso é normal?

    Nota: se esse código aí em cima funcionar no seu VS, vou reformatar a minha máquina.

    Valeu mesmo!

    Galeano

    terça-feira, 23 de setembro de 2014 19:57
  • Cara o VS2013 não tem nada contra o bootstrap, inclusive se vc starta um projeto o template que vem é o bootstrap!

    Vc removeu uma das referencias ao CSS? Deixa somente a do CDN, abaixo:

    <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/bootstrap/3.2.0/css/bootstrap.min.css">



    Blog Breno Queiroz – MCP


    • Editado Breno Queiroz terça-feira, 23 de setembro de 2014 20:02
    • Marcado como Resposta Galeano 2014 terça-feira, 23 de setembro de 2014 20:14
    terça-feira, 23 de setembro de 2014 20:02
  • Funcionou! Perfeito!
    terça-feira, 23 de setembro de 2014 20:14