none
Falha na instalação do EntityFramework 5 em uma Portable Class Library RRS feed

  • Pergunta

  • Teste com Asp.Net Mvc 4

    Mensagem de erro:

    Could not install package 'EntityFramework 5.0.0'. You are trying to install this package into a project that targets '.NETPortable,Version=v4.0,Profile=Profile4', but the package does not contain any assembly references that are compatible with that framework. For more information, contact the package author.

    A Class Library vai tudo bem mas a poortable class library da pau. É isso mesmo?

    Hermes.


    terça-feira, 26 de março de 2013 18:01

Respostas

  • Olá Hermes,

    Sim. A Portable Class Library contém apenas referências a recursos portáveis, que funcionem em diferentes ambientes como Windows Phone, Apps do Windows 8, Dektops apps, aplicações ASP.Net.

    Hoje, o EF não é portável. Não podemos usá-lo em aplicações Windows Phone e Windows 8.

    Além disso, o EF tem referências para outras dependências que não são referências dos Portable Class Libraries. 

    Desta forma, não irá funcionar.

    []s!


    MSc. Fernando Henrique Inocêncio Borba Ferreira
    Microsoft MVP - Visual C#
    while(alive){ this.WriteCode(); }
    Blog: http://ferhenriquef.com/
    Twitter: @ferhenrique
    Entity Framework - Brasil: https://www.facebook.com/EntityFrameworkBrasil

    • Marcado como Resposta Hermes 2013 terça-feira, 26 de março de 2013 19:17
    terça-feira, 26 de março de 2013 18:36
    Moderador