none
Filtrar contas no campo localizar do assistente de formulário (aquele que fica do lado direito) RRS feed

  • Pergunta

  • Pessoas,

    Estou com o seguinte problema:

    (Contexto)
    Na tela de Ocorrências, possuo os campos Grupo de Contas e Clientes (tem mais, mas estes são os importantes agora). A primeira ação é escolher o Grupo de Contas. Quando escolhido passo para o próximo campo que é Clientes. Este quando recebe foco abre-se automaticamente do lado direito, o assistente de formulário com um campo Localizar trazendo todos os Clientes (Contas).

    (Problema)
    Preciso filtrar este campo Localizar (que fica no assistente de formulário no lado direito) para que apareça não todos os clientes, mas sim os clientes que são do grupo de contas X.

    Existe meio?

    Valeu!
    Fabio

    quarta-feira, 7 de julho de 2010 20:38

Respostas

  • Não é possível se filtrar o Assistente de Formulário de maneira suportada. Alterar este componente pode dificultar a migração da ferramenta no futuro.
    []'s Juliano Bassetto - [MCP/MCBMSS] - Semper Fi! Carry On!
    • Sugerido como Resposta Matt Biondi quinta-feira, 8 de julho de 2010 19:12
    • Marcado como Resposta RicardoAlves sábado, 2 de outubro de 2010 18:23
    quinta-feira, 8 de julho de 2010 19:12
  • Fabio,

     

    Utilizando o filtro no campo, você desabilitar o Assistente de Formulário clicando "Propriedades do Formulário" -> "Exibir" e desmarcar item "Habilitar Assitente de Formulário".

     

    Abraços,


    Ricardo Alves
    www.dracomo.com
    • Sugerido como Resposta RicardoAlves quarta-feira, 14 de julho de 2010 01:45
    • Marcado como Resposta RicardoAlves sábado, 2 de outubro de 2010 18:23
    quarta-feira, 14 de julho de 2010 01:45

Todas as Respostas

  • Bom dia,

    Olha se isso te ajuda, estou utilizando para filtrar os estados atravez de um pais escolhido no lookup pais para o lookup estado.

     

    OnLoad

    /*Executando a função no onchange do campo Pais onde vai aplicar o material */
    crmForm.all.new_paisondevaiaplicaromaterialid.FireOnChange();
    crmForm.all.new_estadoondevaiaplicaromaterialid.FireOnChange();
    if(crmForm.all.new_paisondevaiaplicaromaterialid.DataValue != null)
    {
    crmForm.all.new_estadoondevaiaplicaromaterialid.Disabled = false;
    }
    else{crmForm.all.new_estadoondevaiaplicaromaterialid.Disabled = true;}

    if(crmForm.all.new_estadoondevaiaplicaromaterialid.DataValue != null)
    {
    crmForm.all.new_cidadeondevaiaplicaromaterialid.Disabled = false;
    }
    else{crmForm.all.new_cidadeondevaiaplicaromaterialid.Disabled = true;}


    OnChange do campo


    /*Filtrando os valores para o preenchimento do campo estado de acordo com o país escolhido*/
    if (crmForm.all.new_paisondevaiaplicaromaterialid.DataValue != null)
    {
        crmForm.all.new_estadoondevaiaplicaromaterialid.Disabled = false;
        SetarNovoFiltroEstado();
    }
    function SetarNovoFiltroEstado()
    {
        var searchVal = crmForm.all.new_paisondevaiaplicaromaterialid.DataValue[0].name;
       if (searchVal != null)
       {
          searchVal = searchVal.replace("&", "%26");
          crmForm.all.new_estadoondevaiaplicaromaterialid.additionalparams = "search=" + searchVal;
        }
    }


    Tiago Henrique Consultor de Implantação Microssoft Dynamics CRM
    quinta-feira, 8 de julho de 2010 11:39
  • Não é possível se filtrar o Assistente de Formulário de maneira suportada. Alterar este componente pode dificultar a migração da ferramenta no futuro.
    []'s Juliano Bassetto - [MCP/MCBMSS] - Semper Fi! Carry On!
    • Sugerido como Resposta Matt Biondi quinta-feira, 8 de julho de 2010 19:12
    • Marcado como Resposta RicardoAlves sábado, 2 de outubro de 2010 18:23
    quinta-feira, 8 de julho de 2010 19:12
  • Fabio,

     

    Utilizando o filtro no campo, você desabilitar o Assistente de Formulário clicando "Propriedades do Formulário" -> "Exibir" e desmarcar item "Habilitar Assitente de Formulário".

     

    Abraços,


    Ricardo Alves
    www.dracomo.com
    • Sugerido como Resposta RicardoAlves quarta-feira, 14 de julho de 2010 01:45
    • Marcado como Resposta RicardoAlves sábado, 2 de outubro de 2010 18:23
    quarta-feira, 14 de julho de 2010 01:45