none
APPCONFIG - WINFORM - PROBLEMAS RRS feed

  • Pergunta

  • Pessoal, estou com um problema um pouco complicado. Estou tentando modificar a string de conexão do appconfig através do código que vi no forum, seguinte:

     


                try
                {
                    System.Configuration.Configuration config = System.Configuration.ConfigurationManager.OpenExeConfiguration(System.Configuration.ConfigurationUserLevel.None);
                    //System.Configuration.ConfigurationManager.RefreshSection("appSettings");
                    config.ConnectionStrings.ConnectionStrings["INTRANET.Properties.Settings.MKaravellaConnectionString"].ConnectionString = new BancoDados().conexao2010;

                    config.Save(System.Configuration.ConfigurationSaveMode.Modified);
                    System.Configuration.ConfigurationManager.RefreshSection("appSettings");
                }
                catch (Exception)
                {

                }

    O grande problema é que eu utilizo vários projetos no team system, ou seja, financeiro é um projeto... estoque é outro projeto... ai, tenho uma tela principal que é outro projeto e que chama os projetos secundarios... Ou seja, um projeto menu... Meu problema é que, esse código acima funciona perfeitamente executando no projeto em especifico, ou seja separado. Quando eu coloco ele no meu, ele da um erro de instancia de objeto. O que pode ser? Obrigado.

    terça-feira, 25 de maio de 2010 21:40

Todas as Respostas