none
Vista x Framework RRS feed

  • Pergunta

  • Pessoal boa tarde ,

    Estou com o seguinte problema com meu site. Eu desenvolvi ele em cima do framework que ja vem instalado no windows vista se não me engano é o 3.0, so que na hora que hospedei o site em um servidor pago o mesmo apresenta o seguinte erro:


    Server Error in '/' Application.

    Unable to find the requested .Net Framework Data Provider.  It may not be installed.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.ArgumentException: Unable to find the requested .Net Framework Data Provider.  It may not be installed.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [ArgumentException: Unable to find the requested .Net Framework Data Provider.  It may not be installed.]
    System.Data.Common.DbProviderFactories.GetFactory(String providerInvariantName) +1447431
    System.Web.UI.WebControls.SqlDataSource.GetDbProviderFactory() +63
    System.Web.UI.WebControls.SqlDataSource.GetDbProviderFactorySecure() +19
    System.Web.UI.WebControls.SqlDataSourceView.ExecuteSelect(DataSourceSelectArguments arguments) +120
    System.Web.UI.DataSourceView.Select(DataSourceSelectArguments arguments, DataSourceViewSelectCallback callback) +17
    System.Web.UI.WebControls.DataBoundControl.PerformSelect() +149
    System.Web.UI.WebControls.BaseDataBoundControl.DataBind() +70
    System.Web.UI.WebControls.FormView.DataBind() +4
    System.Web.UI.WebControls.BaseDataBoundControl.EnsureDataBound() +82
    System.Web.UI.WebControls.FormView.EnsureDataBound() +163
    System.Web.UI.WebControls.CompositeDataBoundControl.CreateChildControls() +69
    System.Web.UI.Control.EnsureChildControls() +87
    System.Web.UI.Control.PreRenderRecursiveInternal() +50
    System.Web.UI.Control.PreRenderRecursiveInternal() +170
    System.Web.UI.Control.PreRenderRecursiveInternal() +170
    System.Web.UI.Control.PreRenderRecursiveInternal() +170
    System.Web.UI.Control.PreRenderRecursiveInternal() +170
    System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2041


    Version Information: Microsoft .NET Framework Version:2.0.50727.1433; ASP.NET Version:2.0.50727.1433

    Que eu acredito ser por causa da versão do Framework do servidor que é a versão 2.0.50727. Entre em contato com o pessoal do servidor é realmente esta a versão do Framework do servidor.

    A questão é a seguinte tem como eu passar este site para esta versão do Framework ? Vai ser necessario desinstalar a versão que ja veio no vista ? E tem como  desenvolver um site no vista usando o
    Framework 2.0.50727 ?

    Um detalhe estou usando o conector do mysql para conectar a uma base de dados mysql.

    Na pasta Bin eu já coloquei a DLL MySql.Data.dll ...

    Localmente o site funciona normal , sem problemas.

    Se algume poder me ajudar agradeço ...

    Obrigado,
    segunda-feira, 27 de outubro de 2008 16:33

Respostas

  • Opa, o Visual Studio 2005 só desenvolve para o Framework 2.0

    o que pode estar acontecendo é que no seu servidor ele não está configurado para aceitar o seu provider. Verifique com o seu provedor, se para vc utilizar este provider está tudo ok.


    segunda-feira, 27 de outubro de 2008 16:44

Todas as Respostas

  • VC está utilizando que ferramenta para desenvolvimento.?
    segunda-feira, 27 de outubro de 2008 16:35
  • Ola Kelvin desculpe esqueci de colocar , uso o visual studio 2005.
    segunda-feira, 27 de outubro de 2008 16:36
  • Opa, o Visual Studio 2005 só desenvolve para o Framework 2.0

    o que pode estar acontecendo é que no seu servidor ele não está configurado para aceitar o seu provider. Verifique com o seu provedor, se para vc utilizar este provider está tudo ok.


    segunda-feira, 27 de outubro de 2008 16:44
  • Menos mau então ... para mim o site era desenvolvido no framework que o windows tem instalado ... mais se é assim fica mais facil para resolver , vou entrar em contato com o pessoal do servidor e pedir para eles verificarem.

    Muito obrigado Kelvin me ajudou muito ....



    segunda-feira, 27 de outubro de 2008 16:48