none
Problema OpenCV2.0 + windows 7 RRS feed

  • Pergunta

  • Bom dia galera,

    Construir um sistema em c#, ele usa uma dll feita em c++ de captura utilizando OpenCV 2.0.

    O problema é que no windows XP funciona legal, já no windows 7 acontece um atraso na comunicação, não sei o motivo, a dll demora para retornar a resposta, alguem já vivenciou algo parecido ou saberia algum indicio do problema ?
    • Movido Erick Albuquerque sexta-feira, 15 de julho de 2011 01:35 Forum apropriado. (De:Interoperabilidade - Geral)
    quinta-feira, 14 de julho de 2011 12:53

Todas as Respostas

  • Não foi objetivando ser usada no OS Windows 7 e foi utilizado VS2008, tanto o sistema em C# quanto a compilação do OpenCV foram feitas em XP. Vou testar com o VS2010 e posto aqui o resultado.

    Obrigado

    sexta-feira, 15 de julho de 2011 13:04
  • Demorei, mas fiz os testes compilando a aplicação no visual studio 2010, fiz a compilação da aplicação e da dll de captura de video, por algum motivo não captura nada a dll quando compilada no 2010.

    Do jeito que estava antes, a dll precisava estar em modo de compatibilidade com o xp, para só assim rodas no 7, talvez isso ajude na identificação do problema.

    Ainda vou testar outros pontos, se alguem puder me direcionar para uma melhor alternativa, fico agradecido.
    quarta-feira, 27 de julho de 2011 16:52
  • Você já leu a documentação desta biblioteca? Talves você encontre uma resposta! Sempre antes de usar uma biblioteca é bom ler a documentação!

     Dá uma olhada neste link, que fala sobre a compatibilidade de sistemas operacinais com a opencv:

    http://opencv.willowgarage.com/wiki/FullOpenCVWiki#Welcome.2BAC8-OS.WindowsVersion


    Qual é o caminho para ser um bom programador?! Resp: Estudar, estudar e estudar...

    quarta-feira, 27 de julho de 2011 17:16
  • Obrigado pelas dicas, mas respondendo:

    Resposta 1: Sim, sem mensagens warning.
    Resposta 2: Nenhuma mensagem de erro por parte do programa ou dll, tudo ocorre normalmente, o unico problema se da pelo atraso.

    Resposta 3: Esse é sem duvida um característica que não havia observado, acredito que poderia ser mesmo nesse sentido o problema.
    Mas como não entendo bem do funcionamento do S.O, então não sabia que o modo de compatibilidade tem relação com drivers desatualizados do dispositivo, se isso confere, vou verificar no site do fabricante, no caso utilizamos uma placa de captura PCI, onde é conectado a respectiva câmera, poderia ser esse recurso o conflitante dessa compatibilidade exigida pelo S.O ?

    Muito obrigado mais uma vez pela atenção.

     

     

    sexta-feira, 29 de julho de 2011 17:10