none
UpdateProgress não funciona com FileUpload RRS feed

  • Pergunta

  • Olá,

    Eu tenho o UpdateProgress funcionando em algumas páginas do meu sistema, porém em uma determinada não está.

    Nessa página eu queria que uma imagem CARREGANDO fosse exibida enquanto estivesse sendo feito o upload do arquivo, porém o upload é executado sem que a imagem (ou texto, nada é exibido) de dentro do updateProgress seja exibida.

    Alguém sabe o que pode ser?

                <asp:UpdatePanel ID="pnImportarDados" UpdateMode="Conditional" runat="server">
                    <ContentTemplate>
                        <div class="panel panel-default">
                            <div class="panel-body">
                                <div class="box">
                                    <div class="box-title">
                                        <h4 class="form-title">Report</h4>
                                    </div>
                                </div>
    
                                <div class="col-form1" style="margin-bottom: 10px">
                                    <div class="col-md-12">
                                        <div class="panel panel-primary">
                                            <div class="panel-heading">
                                                <h3 class="panel-title"><i class="fa fa-line-chart"></i>IMPORTAR DADOS</h3>
                                            </div>
                                            <div class="panel-body">
                                                <p>
                                                    <br>
                                                    Selecione o aquivo <b>.CSV</b><asp:Label ID="txtTeste" runat="server" Text=""></asp:Label>
                                                </p>
                                                <br />
                                                <asp:FileUpload ID="fuImportarDados" CssClass="custom-file-input btn-block" runat="server" /><br />
                                                <br />
                                                <asp:Button ID="btnEnviaImportarDados" CssClass="btn btn-primary btn-block" OnClick="btnEnviaImportarDados_Click" runat="server" Text="Enviar" />
                                                <br />
                                            </div>
                                        </div>
                                    </div>
                                </div>
    
                            </div>
                        </div>
    
    
                        <asp:UpdateProgress ID="updGerarExcel" AssociatedUpdatePanelID="pnImportarDados" runat="server">
                            <ProgressTemplate>
                                Carregando...................
                                <div class="modal-backdrop" style="z-index: 9999; opacity: 0.8;">
                                    <div class="div_load">
                                        <div class="texto_load">
                                            <img src="ico_loader.gif" width="40px" /><br>
                                            Carregando...
                                        </div>
                                    </div>
                                </div>
                            </ProgressTemplate>
                        </asp:UpdateProgress>
    
                    </ContentTemplate>
                    <Triggers>
                        <asp:PostBackTrigger ControlID="btnEnviaImportarDados" />
                    </Triggers>
    
                </asp:UpdatePanel>

    terça-feira, 8 de agosto de 2017 19:15

Respostas

Todas as Respostas

  • Inspecione a página e veja se nenhuma classe ou atributo do ProgressTemplate ou filhos está fazendo com que o elemento não seja mostrado.
    Por exemplo, veja se a classe 'modal-backdrop' está com display none, etc.
    quarta-feira, 9 de agosto de 2017 14:12
  • Só tenho isso na página, não tem filhos.
    quinta-feira, 10 de agosto de 2017 18:01
  • Boa tarde, wcsantos.

    Tudo bem?

    Conseguiu resolver teu problema? Se ainda não, nos explique o que ainda precisa, para que possa ser ajudado.

    Atenciosamente,

    Filipe B de Castro

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    sexta-feira, 18 de agosto de 2017 20:00
    Moderador
  • Bom dia,

    Por falta de retorno, essa thread está encerrada.

    Se necessário, favor abrir uma nova thread.

    Atenciosamente,

    Filipe B de Castro

    Esse conteúdo é fornecido sem garantias de qualquer tipo, seja expressa ou implícita

    MSDN Community Support

    Por favor, lembre-se de Marcar como Resposta as postagens que resolveram o seu problema. Essa é uma maneira comum de reconhecer aqueles que o ajudaram e fazer com que seja mais fácil para os outros visitantes encontrarem a resolução mais tarde.

    segunda-feira, 21 de agosto de 2017 13:16
    Moderador