none
Níveis de aninhamento em fórmulas no excel? RRS feed

  • Pergunta

  • Boa tarde! Tenho uma formula que tentei usar o SE e o PROCV  mas quando dou enter para validar retorna o seguinte erro: "A fórmula especificada não pode ser inserida porque ela usa mais níveis de aninhamento do que o permitido no formato de arquivo atual". Alguem sabe como posso conseguir validar alguma das 2 formulas?

    =SE(A13>=E8; 
    SE(A13<=E7;F8; 
    SE(A13>=E7; 
    SE(A13<=E6;F7; 
    SE(A13>=E6; 
    SE(A13<=E5;F6; 
    SE(A13>=E5; 
    SE(A13<=E4;F5;
    SE(A13>=E5;F6;
    )))))))))


    =PROCV(A13>=E8; 
    PROCV(A13<=E4:F8;2;0; 
    PROCV(A13>=E7; 
    PROCV(A13<=E4:F8;2;0; 
    PROCV(A13>=E6; 
    PROCV(A13<=E4:F8;2;0; 
    PROCV(A13>=E5; 
    PROCV(A13<=E4:F8;2;0;
    PROCV(A13>=E8;E4:F8;2;0;
    )))))))))

    


    Clansman

    sexta-feira, 18 de outubro de 2013 17:24

Respostas

  • Se seu Excel for 2003 ou inferior, apenas 7 níveis de aninhamento são permitidos.

    Uma forma de driblar essa limitação é você quebrar sua fórmula em três células. Coloque a metade dos aninhamentos em cada célula, e então a terceira fórmula será um SE que buscará informação de uma das duas células.

    Há um artigo em inglês que detalha bem essa questão: http://www.cpearson.com/excel/nested.htm



    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    domingo, 20 de outubro de 2013 17:44
    Moderador