none
Problema na execução de um software distribuido RRS feed

  • Pergunta

  • Olá pessoal, estou com o seguinte problema: ao distribuir o meu software que funciona normalmente em meu computador, o cliente instala normalmente, porém ao executar o software depois de instalado antes de abrir aparece uma janela do windows com o seguinte aviso:

    "NomeDoSoftware parou de funcionar"

     

    O windows pode verificar online se há uma solução para o problema

     

    (botão)Exibir detalhes do problema <- ao clicar no botão:

     

     

    Descrição:

     

      Stopped working

     

     

     

    Assinatura do problema:

     

      Nome do Evento de Problema: CLR20r3

     

      Assinatura do Problema 01: vendorbeauty.exe

     

      Assinatura do Problema 02: 1.0.0.0

     

      Assinatura do Problema 03: 4e5d26f1

     

      Assinatura do Problema 04: VendorBeauty

     

      Assinatura do Problema 05: 1.0.0.0

     

      Assinatura do Problema 06: 4e5d26f1

     

      Assinatura do Problema 07: 12a6

     

      Assinatura do Problema 08: 53

     

      Assinatura do Problema 09: System.IO.FileNotFoundException

     

      Versão do sistema operacional:  6.1.7600.2.0.0.256.1

     

      Identificação da Localidade:

    1046

     

     

     

    Leia nossa declaração de privacidade online:

     

      http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0416

     

     

     

    Se a declaração de privacidade online não estiver disponível, leia nossa declaração de privacidade offline:

     

      C:\Windows\system32\pt-BR\erofflps.txt

     

    ************************************************************************************************

     

    Preciso urgente resolver este problema,

     

    Agradeço desde já,

     

    Wesley Olivier

    terça-feira, 30 de agosto de 2011 18:59

Todas as Respostas

  • Wesley,

    Isto parece problema com o Framework. Você já tentou reinstalar ?

    []s,


    Carlos dos Santos
    blog: www.carloscds.net 
    twitter: @cdssoftware

    terça-feira, 30 de agosto de 2011 19:30
  • Carlos, creio que não seja o Framework, pois tenho outra aplicação distribuida com os mesmos componentes e roda normalmente!
    terça-feira, 30 de agosto de 2011 19:43
  • Carlos, olharei link por link e tentarei resolver o problema, dando certo ou não, postarei aqui para saber!!!!

    Agradeço desde já!

    Vamos ver....

    quarta-feira, 31 de agosto de 2011 12:31
  • Carlos e Galera, consegui resolver o problema, mas não da melhor forma! =D

    Para o software funcionar em qualquer outro cliente, estou tendo que criar um instalador do próprio Visual Studio e instalar, pois acredito que assim ele anexa algum componente que com outro instalador não é anexado.

    Se souberem de mais alguma coisa favor postar aqui.

    Obrigado Carlos,

    Att,

    Wesley Olivier

     

     

    quarta-feira, 31 de agosto de 2011 18:07
  • Pessoal,

    Depois de muita pesquisa consegui descobrir que existe dois arquivos dentro da pasta C:\Windows\System32\ServerManager\Cache que são essencias para o funcionamento da ferramenta.

    CbsUpdateInfo.bin
    CbsUpdateState.bin

    Vamos lá, dentro da pasta C:\Windows\logs existe o arquivo chamado ServerManager, abri o arquivo e estava apresentando a seguinte mensagem;

    2640: 2012-04-17 09:15:15.205 [LoadExtensionAssemblies]   No extension assemblies registered.
    2640: 2012-04-17 09:15:15.505 [OobOptionalComponentInfo]  Loading OCs from registry.
    2640: 2012-04-17 09:15:15.506 [OobOptionalComponentInfo]  Name: '%windir%\system32\wsmsvc.dll,103', description: '%windir%\system32\wsmsvc.dll,104', discovery hint: 'Microsoft-Windows-Web-Services-for-Management-IIS-Extension', install command: 'ocsetup.exe WAS-WindowsActivationService;WAS-ProcessModel;WAS-ConfigurationAPI;IIS-WebServerRole;IIS-WebServerManagementTools;Microsoft-Windows-Web-Services-for-Management-IIS-Extension /quiet', uninstall command: 'ocsetup.exe Microsoft-Windows-Web-Services-for-Management-IIS-Extension /uninstall /quiet /norestart'
    2640: 2012-04-17 09:15:15.583 [OobOptionalComponentInfo]  Localized name: 'Extensão do IIS do WinRM', localized description: 'Extensão do IIS do WinRM'
    2640: 2012-04-17 09:15:17.404 [CBS]                       LastModified CBS Time (UTC): 01/11/2012 20:57:20
    2640: 2012-04-17 09:15:17.405 [Provider]                  C:\Windows\system32\ServerManager\Cache\CbsUpdateState.bin does not exist.
    2640: 2012-04-17 09:15:17.405 [CBS]                       IsCacheStillGood: False.
    2640: 2012-04-17 09:15:17.406 [CBS]                       CreateSessionAndPackage: begin
    2640: 2012-04-17 09:15:17.512 [CBS] Error (Id=0) Function: 'CreateSessionAndPackage()->CoCreateInstance' failed: 80004002 (-2147467262)
    2640: 2012-04-17 09:15:17.886 [ExceptionHandler] Error (Id=0) Exceção inesperada:
    System.InvalidCastException: Conversão especificada não é válida.
       em System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
       em Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(IntPtr& session, IntPtr& package)
       em Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
       em Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
       em Microsoft.Windows.ServerManager.Common.Provider.Initialize(DocumentCollection documents)
       em Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Object state)

    Para resolver o problema eu acessei um servidor com a mesma versão do windows e service pack, copiei os arquivos e colei no diretorio C:\Windows\System32\ServerManager\Cache.

    Pronto o ServerManager voltou a funcionar.
    • Sugerido como Resposta André Galbiatti segunda-feira, 27 de agosto de 2012 20:52
    segunda-feira, 21 de maio de 2012 22:05