none
CONFERIR resultados RRS feed

  • Pergunta

  • Boa tarde

    Estou fazendo uma formula de conferencia de resultados

    No intervalo i12:i299 há varias formulas (procv) que resgatam informações de outras planilhas conforme orientação

    Entretanto nem todas essas linhas serão utilizada (conforme processo) assim muitas células apresentarão a informação #N/D

    Preciso verificar se a informação nas células diferente de #n/d são iguais a "USD" se o resultado por verdadeiro retornar como USD

    Caso contrário deve verificar se todos são iguais a "EUR" se sim retornar EUR

    e se os resultados não forem iguais entre si (tivermos uns USD e outros EUR) retornar ERRO

    Tentei utilizar o:

    =SE(I2:I289="USD";"USD";SE(I2:I289="EUR";"EUR;""ERRO"))

    mas dessa forma ele verifica as linhas com #N/D e até as embranco

    Alguém saberia como como resolver esse desafio?

    quarta-feira, 1 de abril de 2015 17:27

Respostas

  • Olá Igor, se você quiser a fórmula do jeito que você explicou na pergunta, pode utilizar:

    =SE(CONT.SE(I2:I289;">=a")=CONT.SE(I2:I289;"USD");"USD";SE(CONT.SE(I2:I289;">=a")=CONT.SE(I2:I289;"EUR");"EUR";"ERRO"))

    E tenho um comentário para fazer. Não considero uma boa prática deixar visível os valores de errros (#VALOR, #N/D...) na planilha, pois deixa sua planilha esteticamente feia. O recomendado é você aninhar todas funções que podem resultar num erro dentro da função SEERRO. A sintaxe é simples: =SEERRO(Sua fórmula aqui;"Caractere para aparecer na célula quando der erro"). O mais comum é utilizar "" no segundo argumento, por exemplo, =SEERRO(PROCV(A1;I2:J289;2;0);"")

    A fórmula que coloquei vai funcionar da mesma forma se você fizer este ajuste.

    Abraços!


    Rafael Kamimura

    • Marcado como Resposta IgorJardim sexta-feira, 3 de abril de 2015 23:46
    quarta-feira, 1 de abril de 2015 18:25

Todas as Respostas

  • Olá Igor, se você quiser a fórmula do jeito que você explicou na pergunta, pode utilizar:

    =SE(CONT.SE(I2:I289;">=a")=CONT.SE(I2:I289;"USD");"USD";SE(CONT.SE(I2:I289;">=a")=CONT.SE(I2:I289;"EUR");"EUR";"ERRO"))

    E tenho um comentário para fazer. Não considero uma boa prática deixar visível os valores de errros (#VALOR, #N/D...) na planilha, pois deixa sua planilha esteticamente feia. O recomendado é você aninhar todas funções que podem resultar num erro dentro da função SEERRO. A sintaxe é simples: =SEERRO(Sua fórmula aqui;"Caractere para aparecer na célula quando der erro"). O mais comum é utilizar "" no segundo argumento, por exemplo, =SEERRO(PROCV(A1;I2:J289;2;0);"")

    A fórmula que coloquei vai funcionar da mesma forma se você fizer este ajuste.

    Abraços!


    Rafael Kamimura

    • Marcado como Resposta IgorJardim sexta-feira, 3 de abril de 2015 23:46
    quarta-feira, 1 de abril de 2015 18:25
  • Muito Obrigado pela dica!

    Estou alterando as formulas para que não apresentem #N/D

    Valeu pela formula da conferencia

    OBRIGADO

    quarta-feira, 1 de abril de 2015 18:40
  • De nada!

    Só não esqueça de marcar a minha postagem como resposta.

    Value!


    Rafael Kamimura

    quarta-feira, 1 de abril de 2015 19:24