locked
Localizar texto através de uma parte e retornar o texto completo RRS feed

  • Pergunta

  • Olá, estou precisando fazer uma pesquisa em um intervalo de uma coluna (LISTA OK) com textos, utilizando apenas uma parte do texto(LISTA DE PESQUISA) e que de modo silimar ao PROCV ele retorne o valor com o texto inteiro (TEXTO SUBSTITUIDO) Ex:
     
    LISTA OK     LISTA DE PESQUISA   TEXTO SUBSTITUIDO  
    Adamastor, Rua       Aimará   Aimará, Rua    
    Adelardo Caiuby, Rua       caiuby   Adelardo Caiuby, Rua    
    Adoniran Barbosa, Rua       ágata   Ágata, Rua    
    Afonso Delidério, Rua       adamastor   Adamastor, Rua    
    Ágata, Rua              
    Agostinho Marreiro, Rua              
    Água Branca, Rua              
    Águas de São
    sexta-feira, 18 de setembro de 2009 01:27

    Todas as Respostas

    • Não consegui entender muito bem, tem como você explicar melhor, ou me enviar a planilha por e-mail para que eu possa entender melhor o que você quer?

      e-mail: ahorta@yamana.com

      Abraço
      ...
      sexta-feira, 18 de setembro de 2009 14:58
    • Consegui fazer com esta fórmula  inserida na Celula F3 =PROCV(F2&E2&F2;B1:C9;1;FALSO).

      1 A B C D E F  
      2
      LISTA OK
        LISTA DE PESQUISA   TEXTO SUBSTITUIDO  
      3 Adamastor, Rua     adoniran * Adoniran Barbosa, Rua    
      4 Adelardo Caiuby, Rua     caiuby   Adelardo Caiuby, Rua    
      5 Adoniran Barbosa, Rua     ágata   Ágata, Rua    
      6 Afonso Delidério, Rua     adamastor   Adamastor, Rua    
      7 Ágata, Rua      
      8 Agostinho Marreiro, Rua      
      9 Água Branca, Rua      
      10 Águas de São    

      Mesmo assim Obrigado a todos.
      sábado, 19 de setembro de 2009 01:49