none
Erro Inesperado - Reatribuir Registros RRS feed

  • Pergunta

  • Boa tarde a todos!

    Estou com um problema na reatribuição de registros do CRM 2013. Estou tentando reatribuir os registros de um usuário a outros através da entidade de usuários mas esta ocorrendo um "Erro Inesperado" e os registros não são atribuídos. Isso não ocorre em todos usuários.

    segue o Log do erro apresentado pelo sistema.

    Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=6.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: Published workflow definition must have non null activation id.Detail: 
    <OrganizationServiceFault xmlns:i="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://schemas.microsoft.com/xrm/2011/Contracts">
      <ErrorCode>-2147220970</ErrorCode>
      <ErrorDetails xmlns:d2p1="http://schemas.datacontract.org/2004/07/System.Collections.Generic" />
      <Message>Published workflow definition must have non null activation id.</Message>
      <Timestamp>2014-11-07T18:09:06.5663868Z</Timestamp>
      <InnerFault i:nil="true" />
      <TraceText i:nil="true" />
    </OrganizationServiceFault>

    Alguém sabe como resolver esse problema?

    Valeu pessoal.

    Abraços.

    sexta-feira, 7 de novembro de 2014 18:40

Todas as Respostas

  • Boas Felippe,

    Estás num ambiente online ou on-premise? Se for on-premise, de onde tirastes este erro, da interface ou do trace? Se não foi do trace, ativa o trace e verifica se tens mais detalhes. Esse utilizador era owner de algum workflow?

    Espero ter ajudado.
    Se respondi a sua pergunta por favor marque como resposta e\ou como útil.


    Pedro Azevedo Crm Specialist 4.0\2011

    • Sugerido como Resposta Azevedo PedroMVP segunda-feira, 10 de novembro de 2014 13:20
    segunda-feira, 10 de novembro de 2014 13:20
  • Boas Pedro,

    O ambiente é online. O erro é referente ao Log gerado pelo próprio CRM.

    Sim, é administrador do sistema e era owner de diversos workflows. Esse workflows ja foram trocados de owner, deletados e o problema continua.

    terça-feira, 11 de novembro de 2014 14:39
  • Boas Felippe,

    Tens a certeza que não tem mais workflows ou algum processo? Tenta realizar uma pesquisa avançada pelos processos. Sendo CRM Online podes abrir um incidente para a equipa do CRM Online que eles ajudam.

    Espero ter ajudado.
    Se respondi a sua pergunta por favor marque como resposta e\ou como útil.


    Pedro Azevedo Crm Specialist 4.0\2011

    • Sugerido como Resposta Azevedo PedroMVP segunda-feira, 17 de novembro de 2014 23:29
    segunda-feira, 17 de novembro de 2014 23:29