none
RequireHTTPS RRS feed

  • Pergunta

  • Olá pessoal, estou utilizando essa notação para decorar as actions em que quero forçar o uso do certificado SSL, e está entrando em loop ao ser publicado, não consigo saber se o problema é na aplicação ou no servidor, local funciona normalmente, agradeço qqr ajuda.

    terça-feira, 18 de dezembro de 2012 08:20

Todas as Respostas

  • Esta hospedando seu site aonde?

    Paulo Marcelo Dalbosco

    terça-feira, 18 de dezembro de 2012 11:44
  • Olá Paulo, estamos hospedados no cloud da Dualtec (http://www.dualtec.com.br).

    Infelizmente ainda não identificamos esse comportamento estranho, já levamos em consideração um possível conflito do RequireHttps com o Load Balancer, mas não encontramos nenhuma solução plausível, todos os nossos testes deram o mesmo resultado ou não entraram de fato em ambiente seguro, o site todo navega normalmente com exceção da nossa tela de pagamento.

    A mensagem que aparece no firefox é: "Erro 310 (net::ERR_TOO_MANY_REDIRECTS): Houve muitos redirecionamentos."

    terça-feira, 18 de dezembro de 2012 13:46
  • Você comentou que esta funcionalidade se comporta normalmente em localhost.

    Provavlemente é alguma configuração do servidor, uma vez tive problemas parecidos com a LocaWeb, o suporte deles me deram todas as diretivas para configurar meu WebMail.

    Vc ja tentou entrar em contato com eles?


    Paulo Marcelo Dalbosco

    terça-feira, 18 de dezembro de 2012 16:03
  • Sim, passamos a madrugada em contato com eles. O suporte teve boa vontade, mas infelizmente nem nossa equipe daqui e nem a equipe de lá achou o problema. 

    Assim que encontrarmos a solução posto aqui.

    terça-feira, 18 de dezembro de 2012 18:10