none
Acento em link RRS feed

  • Pergunta

  • Bom dia,

    Estou utilizando uma web part de editor de conteúdo com o seguinte conteúdo:

    <a href='http://meuportal/_layouts/searchresults.aspx?k="Saúde"&u=http:/meuportal&v1=date'>Saúde</a>

    Esse link cai na página de pesquisa e busca todos os conteúdos com a palavra Saúde.

    O problema é que ele não está entendendo o acento, esta retornando um caracter especial. Alguem já teve esse problema?

    Abs,



    quarta-feira, 14 de março de 2012 14:49

Respostas

  • Olá,

    Saúde = Sa%C3%BAde.

    Porém, ao pesquisar por Saude, saude, Saúde ou saúde, a busca deveria retornar os resultados correspondentes.

    Sua pesquisa deve estar configurada de maneira errada.

    Abraço


    ROBERTOSLJUNIOR

    • Marcado como Resposta Rafael Fausto segunda-feira, 19 de março de 2012 20:01
    segunda-feira, 19 de março de 2012 18:57

Todas as Respostas

  • Ninguem teve problema parecido?!?
    quinta-feira, 15 de março de 2012 18:11
  • Rafael,

    Tenta passar o "ú" codificado na URL ao invés de passar no "ú" passe "%FA": http://www.degraeve.com/reference/urlencoding.php


    Atenciosamente,

    Fabian André Gehrke
    MCITP e MCPD SharePoint 2010
    http://fabiangehrke.com.br

    sexta-feira, 16 de março de 2012 22:08
    Moderador
  • Fabian,

    Fiz a alteração e mesmo assim não funciona.

    Obs.: Estou realizando o teste no firefox.


    segunda-feira, 19 de março de 2012 18:29
  • Olá,

    Saúde = Sa%C3%BAde.

    Porém, ao pesquisar por Saude, saude, Saúde ou saúde, a busca deveria retornar os resultados correspondentes.

    Sua pesquisa deve estar configurada de maneira errada.

    Abraço


    ROBERTOSLJUNIOR

    • Marcado como Resposta Rafael Fausto segunda-feira, 19 de março de 2012 20:01
    segunda-feira, 19 de março de 2012 18:57
  • Roberto,

    A pesquisa está funcionando corretamente. A questão é que eu queria colocar no link como saúde.

    Funcionou do jeito que você colocou. Agora a pergunta, da onde vem o %C3%BA = ú?

    Abs,

    Rafael Fausto

    segunda-feira, 19 de março de 2012 20:01
  • A string está codificada em UTF-8

    Você poderia utilizar seu link dessa maneira:

    <a href='http://site/_layouts/searchresults.aspx?k="saude"'>Saúde</a>

    Referencia: http://www.utf8-chartable.de/


    ROBERTOSLJUNIOR

    segunda-feira, 19 de março de 2012 20:16