none
Pagseguro - não acontece nada na página de retorno! RRS feed

  • Pergunta


  • Olá!

    Alguém já implementou o Pagseguro??

    Quando mando redirecionar para  a página de retorno não acontece nada, ele só redireciona para a página de deveria fazer a validação dos dados "https://pagseguro.uol.com.br/Security/NPI/Default.aspx"  mas ao fazer isso nenhuma validação é feita e nada acontece!

    Alguém pode me ajudar?

    Obrigada!!

    quinta-feira, 12 de junho de 2008 16:27

Respostas

Todas as Respostas

  • Juliana, acho q vc deveria entrar em contato direto com o pessoal do PagSeguro. Talvez eles possam te ajudar melhor.

     

    [ ]s.

    sexta-feira, 27 de junho de 2008 19:33
  • Oi !

     

    Por uma questão de puro acaso estou implementando o pagSeguro, utilizando o carrinho de compras deles.

     

    Nesse caso, não é omeu código que redireciona para a página de retorno, são eles que, depois da compra, redirecionam para a página de retorno. A página de retorno é configurada no painel de controle deles.

     

    []'s

     

    Dennes

    http://www.bufaloinfo.com.br

    http://cidadaocarioca.blogspot.com

     

    quarta-feira, 2 de julho de 2008 01:57
  • Juliana, támbém tive esse mesmo problema com o retorno automático do PagSeguro.

    Depois de muita insistencia consegui colocar pra funcionar.

    Tenho o código completo do retorno automatico em C# .NET e em PHP.
    Caso aja interesse podemos negociar o valor do código.

    Abraço

     

    segunda-feira, 7 de julho de 2008 13:07
  •  

    Oi Reginaldo,

    Utilizo o Visual Studio 2005 e estou com problemas em implementar o retorno automatico em C#, a pagina que tento pegar os dados de retorno não retorna NADA, tenho interesse em negociar a solução.
    MSN e e-mail: blr@grnegocios.com.br.

    sexta-feira, 3 de outubro de 2008 17:11
  • Pessoal,

    Disponibilizei em meu website um código COMPLETO desenvolvido em .NET com muitos comentários, excelente para aprendizado e inserção direta no seu website.

    Os códigos estão disponíveis em C#.net (http://www.oticasnet.com.br/Downloads/NPIPagSeguroCS.zip) e em VB.net (http://www.oticasnet.com.br/Downloads/NPIPagSeguroVB.zip)

    Os próprios projetos são auto-explicativos, ou seja, não há documentação para os mesmos.

    Mesmo sendo desenvolvido em .NET, pode ser facilmente traduzido para outra linguagem, visto que o código está muito detalhado.

    Qualquer dúvida, postar aqui.

    []'s

     

    http://www.oticasnet.com.br

    * Clique nos anuncios do Google pra me ajudar.

    sábado, 11 de outubro de 2008 00:58
  • que vergonha reginaldo, você deveria entrar aqui pra ajudar a comunidade e não comercializar seus códigos.
    quarta-feira, 26 de novembro de 2008 17:31
  • Olá pessoal,

     

    estou tendo problemas para validar o token, ele retorna sempre "FALSO", segui o código de exemplo deles para a validação do retorno automático.

     

    Alguém teve o mesmo problema? Oque pode ser?

     

    Mandei uma solicitação ao suporte mas ainda não obtive resposta.

     

    []'s

     

    quarta-feira, 7 de janeiro de 2009 12:49
  •  Sergio Costa Faria wrote:
    Os códigos estão disponíveis em C#.net (http://www.oticasnet.com.br/Downloads/NPIPagSeguroCS.zip) e em VB.net (http://www.oticasnet.com.br/Downloads/NPIPagSeguroVB.zip)
    `

    Sérgio,

    Parabéns pela atitudo de disponibilizar o seus fontes para download, acredito que não só eu como vários agradecem pela NÃO TENTATIVA DE COMERCIALIZAÇÃO aqui no forum.

    Tiago Borges
    http://www.tiagoborges.net/
    quarta-feira, 7 de janeiro de 2009 13:03
  • Maurício,

     

    Disponibilizei no meu website (http://www.oticasnet.com.br) um FAQ com as principais dúvidas, inclusive o retorno=FALSO.

     

    Dá uma olhadinha lá, que com certeza tem uma resposta perfeita (e detalhada) pra você.

     

    Atenciosamente,

     

    Sergio

    quarta-feira, 7 de janeiro de 2009 13:41
  • Salve Sérgio!

     

    O problema estava no Encode. Não se é alguma coisa nas minhas configurações ou se é algo no UOL, mas quando eu passo dados com Acento, tipo Maurício ele dá diferente, pois lá não reconhece. Então vou forçar minha aplicação a enviar Maurício, mandar ela ignorar acentos. Realmente existe esse problema ou é alguma configuração que eu deixei passar em branco?

     

    []'s

    quarta-feira, 7 de janeiro de 2009 14:36
  • Tiago,

     

    Eu tenho o conhecimento inteiro do PagSeguro, do NPI, das dificuldades que MILHARES de desenvolvedores têm em relação ao mesmo problema, oras... POR QUE COBRAR????

     

    Cobro por outros tipos de serviço, não por este tão simples.

     

    Sempre que precisar, é só falar..

     

    Atenciosamente,

     

    Sergio

    http://www.oticasnet.com.br

    quarta-feira, 7 de janeiro de 2009 17:30
  • Maurício,

     

    A começar, meu nome é sem acento hehehhe....

    Bom, o problema do Encoding é algo existente no PagSeguro e o pessoal aqui está tentando resolver este problema desde a época da BRpay (nome antigo do PagSeguro, antes da venda pro UOL).

    Mas fique tranquilo. Seguindo as orientações que coloquei no FAQ do OticasNet seu código funcionará perfeitamente.

     

    Atenciosamente,

     

    Sergio

    http://www.oticasnet.com.br

     

    quarta-feira, 7 de janeiro de 2009 17:32
  • Sérgio, vi que você postou em diversos fórums essa sua solução, porém nem o domínio oticasnet.com.br existe.
    Por favor, se hospedou em outro lugar, nos envie o novo link.

    Obrigado
    sexta-feira, 23 de outubro de 2009 12:28
  • Sergio,

    Poderia por favor me informa onde consigo pegar seu codigo de retorno???
    Estou tentando a um bom tempo finaliza uma aplicação aberta http://thsispag.thinformatica.com . Porem não passo do retorno automatico. Ja fiz da maneira que pagseguro da de exemplo e nda...se o seu codigo estiver ativo e puder disponibiliza-lo...


    Desde já obrigago!

     

    terça-feira, 5 de outubro de 2010 20:16
  • Tem um post no meu blog que auxilia a integração com o Pagamento Digital, só dar uma olhada e qualquer dúvida fique a vontade para entrar em contato.

     

    http://www.cassiobp.com.br/Blog/post/Integracao-Pagamento-Digital.aspx


    Cássio V1RU5
    terça-feira, 3 de maio de 2011 23:41
  • Senhores,

     

    Acho que o meu problema é parecido com o de vocês (que hoje, já deve ter sido resolvido)...

    Acho que meu problema está na instrução:

    .Executar(this.Response);

    Ele registra no serv de testes do pagseguro, qto ao retorno, eu consigo pegar os dados na página que eu designei, porém, observei que eu perco todas as minhas variáveis de sessão....

    Eu tenho um gridview nessa página... Ele executa o PageLoad, vai para o componente de retorno do PAGSEGURO, consigo gravar no banco, porém, qdo vai preencher a grid com as informações para mostrar o status da compra para o usuário, a minha session foi para o espaço...

     

    Poderiam me dar uma luz??

     

    Obrigado!!!
    mauropn
    sexta-feira, 24 de junho de 2011 12:34
  • Pode ajudar com uma duvida com o Pagseguro e ASP.NET C#.
    Segue meu post.

    http://social.msdn.microsoft.com/Forums/pt-BR/aspnetpt/thread/1f5bc4e2-4feb-48f4-be0f-66525504e214

    Não consigo pegar o POST.

    pode ajudar ?

    segunda-feira, 14 de maio de 2012 11:36