none
Problems loading TFS reports on SharePoint Server 2010 RRS feed

  • Pergunta

  • Hello,

    I'm having problems with TFS reports (like burndown, etc...).

    When I open my SharePoint TeamProject WebSite to see some reports,
    An error is shown with the following message:

    The data connection uses Windows Authentication and user credentials could not be delegated. The following connections failed to refresh:
    TfsOlapReport

    I was looking for a solution to this issue, and it seems to be a common account error betweeb TFS and SharePoint Server 2010.

    I configured SSS on SharePoint and on Team Foundation Server Administration Console, I tried to put on Enterprise Application Definition property an valid account (i put "tfs" that was the account registered on SSS).

    But nothing happens.

    I saw this post and nothing happens:

    http://blogs.msdn.com/b/team_foundation/archive/2010/03/06/configuring-sharepoint-server-2010-beta-for-dashboard-compatibility-with-tfs-2010-beta2-rc.aspx

    Can anyone help me?
    Thank you 

    segunda-feira, 10 de setembro de 2012 19:23

Todas as Respostas

  • Arley,

    Try this:

    • Open the Team Foundation Server Administration Console
    • Click  in Extensions for Sharepoint Products
    • Select Web Application used by TFS
    • Click Modify Access
    • Enter a user with access rights to the reports inside the Enterprise Application (the user configured in the SSS)
    • Click OK.


    Atenciosamente,

    Henderson Andrade
    MCTS
    http://lapartilha.wordpress.com

    terça-feira, 11 de setembro de 2012 17:30
  • I already tried this and the same thing happens.

    I think there is a problem on SSS configuration. But I don't know how to track this issue.

      • I generated a key for the SSS;
      • Created a valid target application "tfs" that relates to the user MyDomain\TFSREPORTS;
      • Opened TFS Admin Console;
      • Selected my TFS Web App;
      • Entered with the SSS target application (tfs) on Enterprise Application Property.

    After this steps, when I try to load the page, the same error is shown.

    Important Note: I can perfectly see the reports on Visual Studio, there is something wrong with Excel Services or SSS.

    Any sugestions?

    terça-feira, 11 de setembro de 2012 18:09
  • Arley,

    The user of SSS have permission in the Reporting Services of TFS?


    Atenciosamente,

    Henderson Andrade
    MCTS
    http://lapartilha.wordpress.com

    terça-feira, 11 de setembro de 2012 18:20
  • Yes.. TFSREPORTS has the access to the Reporting Services on TFS.

    Trying to solve this problem, I just realized that my Reporting Service Account hadn't access to log on locally.

    Now, I can change the SSD ID into the Excel Reports and see the report data editing the excel data.

    But when I save and try to open the report on SharePoint Team Project Portal, other similar error is shown:

    An error occurred while accessing application id TFS from Secure Store Service. The following connections failed to refresh:
    TfsOlapReport 

    Now it says that an error o occurred while trying to access the SSS registered with the ID TFS.

    domingo, 16 de setembro de 2012 16:25