locked
diferença de horas RRS feed

  • Pergunta

  • Olá pessoal

    Tenho um problema que não sou capaz de resolver

    alguém me pode ajudar a ver a diferença de horas

     

    InícioAvar HoraInícioDisf. Fim avaria Hora fim avaria linha parada
    02-Mar 22:00:00 03-Mar  24:00:00 ???????

          isto                           -               isto                      =??? em horas

     

     

    desde já agradeço a vossa ajuda

    Obrigado

    terça-feira, 7 de outubro de 2008 17:21

Respostas

  •  

    De uma olhadinha no seu e-mail.. te mandei a planilha

     

    Veja se esta como você quer.

     

    Um abraço

    quarta-feira, 8 de outubro de 2008 12:52

Todas as Respostas

  • Olá..

     

    Tem como você me mandar a planilha por e-mail?

     

    Eu dou uma olhadinha nela aqui e vejo o que eu consigo fazer, por aqui fica meio dificil entender o que você quer..

     

    e-mail: ahorta@yamana.com

     

    ai eu posto para você aqui o que eu mudei e como eu fiz.

     

    Um abraço.

    terça-feira, 7 de outubro de 2008 18:40
  • Considere que:

     

    * Célula A1 seja a data inicial

    * Célula B1 seja a data final

    * Célula A2 seja a hora inicial

    * Célula B2 seja a hora final

     

    Na célula C2 coloque a seguinte fórmula =((E10-D10)*24+(1440*(E11-D11)/60))*60

    Na célula C3 coloque a seguinte fórmula =SE((E10-D10)>=1;TEXTO((F11/60)/24;"h:mm")+(E10-D10);TEXTO((F11/60)/24;"h:mm"))

     

     

    Veja se deu certo, se não me mande a planilha no e-mail que eu deixei no post de cima

     

    Espero ter ajudado

     

    Um abraço 

    terça-feira, 7 de outubro de 2008 20:06
  • Não,

    percebeste Mal

    o que eu quero é

     

     

        celula A1 data inicial por exemplo 22-Mar

        celula B1 hora inicial 10:22:15

        celula C1 data final 23-Mar

        celula D1 hora final 5:23:20

        agora na celula E1 o tempo que eu demorei em hh:mmTongue Tieds desde do dia 22 até ao dia 23

     

    vê se dá para comprenderes

    obrigado
    terça-feira, 7 de outubro de 2008 20:31
  • Ok.. era só você adaptar para as suas células

    Veja se assim da certo

     

    Considerando que :

     

    celula A1 data inicial por exemplo 22-Mar

    celula B1 hora inicial 10:22:15

    celula C1 data final 23-Mar

    celula D1 hora final 5:23:20

     

    Na célula E1 coloque esta fórmula =((C1-A1)*24+(1440*(D1-B1)/60))*60

    Obs.: Nessa célula você achara o tempo em segundos

     

    Ai na célula F1 coloque esta fórmula =SE((C1-A1)>=1;TEXTO((E1/60)/24;"hh:mm")+(C1-A1);TEXTO((E1/60)/24;"hh:mm"))

    Obs.: Esse será o seu resultado.

     

    Obs.: Não esqueça a formatação das células

     

    Na célula A1 - em formato de Data

    Na célula B1 - em formato de Horas

    Na célula C1 - em formato de Data

    Na célula D1 - em formato de Horas

    Na célula E1 - pode deixar em formato " geral "

    Na célula F1 - primeiro você coloca no formato de hora normal ( HH:MM ), depois vai em personalizado e deixe somente assim (HH:MM).. você consegue editar esse formato em personalizado no quadro onde esta escrito TIPO..

     

    Veja se deu certo..

     

    Abraço

    quarta-feira, 8 de outubro de 2008 11:18
  •  

    De uma olhadinha no seu e-mail.. te mandei a planilha

     

    Veja se esta como você quer.

     

    Um abraço

    quarta-feira, 8 de outubro de 2008 12:52