none
Team Build para Solution C++ RRS feed

  • Pergunta

  • Boa tarde, amigos!

    Tenho uma solução com 32 projetos, sendo que 31 deles são em Managed C++.

    Construí um Team Build para esta solução, mas sempre que rodo recebo mensagens dizendo que certos INCLUDES não foram encontrados. Provavelmente, este problema está no fato de que as pastas de include que são utilizadas pelos projetos não são conhecidas pelo processo do Team Build.

    Como faço para incluir pastas de Include no Team Build?

    Já tentei adicionar uma tag <AdditionalReferencePath Include="..." />, mas não deu certo.

    Alguma idéia?

    Obrigado !!
    quarta-feira, 6 de agosto de 2008 19:08

Respostas

Todas as Respostas

  • Marcio,

     

    A propriedade Build Action do seu arquivo está marcada como o que?? None ??, se estiver, tente marcar como Content. Isso fará o Team Build copiar o arquivo para a pasta temporária onde será executada a compilação e deverá funcionar.

     

    Abraços

    André Dias

     

    quarta-feira, 6 de agosto de 2008 19:35
    Moderador
  • Andre,

     

    Os arquivos em questao sao INCLUDES, e nao fazem parte do projetos C++ ...

    Sao arquivos Header (*.h) ...

     

    No Visual Studio, eu seto a pasta deles como Include Files nas propriedades do Visual Studio (Projects and Solutions -> VC++ Directories -> Include files).

     

    Entende?

     

    Grato ...

    quarta-feira, 6 de agosto de 2008 19:53
  • Marcio

    Esse post TeamBuild and VC++ - adding additional vcbuild options http://blogs.msdn.com/chaitanyacheruvu/archive/2006/06/16/633980.aspx ensina como adicionar algumas configurações do vcbuild no Team Build. Ele mostra como definir uma variavel global INCLUDE para que os projetos consigam ler.

    Dá uma olhada pra ver se resolve o seu problema.

     

    Abraços

    André

     

    quarta-feira, 6 de agosto de 2008 20:02
    Moderador
  • Obrigado, Andre!

     

    O post continha uma abordagem que me ajudou a resolver o problema!

     

    Abraços !!

    quinta-feira, 7 de agosto de 2008 19:54