none
Retornar primeiro valor diferente de zero em um intervalo ? RRS feed

  • Pergunta

  • Prezado,

    tenho em uma determinada planilha um intervalo simples que preciso avaliar, de B3:G3.

    Nesse intervalo tenho algumas colunas com valores iguais a zero. Preciso que seje avaliado esse intervalo, e que me retorne o primeiro valor desse intervalo diferente de zero.

    Ex.:

    Caso B3 for zero, me retorne valor de C4. Caso C4, seje 0, me retorne o valor de D4...... até G3....

    Att,

    Estanislau


    Att, Estanislau Frade msn: lauedele@hotmail.com email: estanislaufrade@yahoo.com.br estanislau.frade@vale.com

    quinta-feira, 18 de abril de 2013 12:49

Respostas

Todas as Respostas

  • Estanislau, não entendi uma coisa: você disse que o intervalo é B3:G3 e no seu exemplo cita células que estão na linha 4.

    Felipe Costa Gualberto - http://www.ambienteoffice.com.br

    sexta-feira, 19 de abril de 2013 21:35
    Moderador
  • Igual exemplo acima....

    Tenho um intevalo a pesquisar de B3:M3, preciso que na linha O3, me retorne o primeiro valor diferente de zero, que nesse caso teria que me retornar o valor de D3 (3,09) que é o primeiro valor diferente de ZERO.


    Att, Estanislau Frade msn: lauedele@hotmail.com email: estanislaufrade@yahoo.com.br estanislau.frade@vale.com

    segunda-feira, 22 de abril de 2013 19:11
  • =ÍNDICE(B3:L3;CORRESP(MENOR(SE(B3:L3=0;1E+300;(B3:L3)*(100^COL(B3:L3)));1);(B3:L3)*100^COL(B3:L3);0))

    Fórmula matricial (Ctrl+Shift+Enter para entrá-la)


    Felipe Costa Gualberto - http://www.ambienteoffice.com.br


    segunda-feira, 22 de abril de 2013 22:10
    Moderador
  • Deu certinho... porém se de uma coluna para outra o valor for vazio ou 0 está dando erro

    O cálculo que solicitei foi encontrar o último valor e reduzir do primeiro...

    56,60 54,70 55,00 60,00 0,00 61,00

    = -56,60 (errado)

    56,60 54,70 55,00 60,00

    = 3,40 (correto)

    sintaxe foi: {=(ÍNDICE(D8:M8;CONT.SE(D8:M8;">1")))-(ÍNDICE(D8:M8;CORRESP(MENOR(SE(D8:M8=0;1E+300;(D8:M8)*(100^COL(D8:M8)));1);(D8:M8)*100^COL(D8:M8);0)))}

    terça-feira, 6 de dezembro de 2016 13:09