locked
Dúvida - Fórmula demasiado grande RRS feed

  • Pergunta

  • Boas, estou com uns problemas no Excel e queria ver se alguém me consegue ajudar!

    Um exemplo:
    Tenho uma tabela com 5 colunas e 5 linhas com os seguintes valores:

    Manuel M Electricista 25Anos 1
    João M Engenheiro 23Anos 0,4
    José M Engenheiro 22Anos 1
    Sérgio M Actor 30Anos 0,2
    Carla F Jornalista 23Anos 1

    Quero contar quantos M tenho que sejam engenheiros, mas cada um só vale o que está especificado na quarta coluna... ou seja terei 1,4.

    A fórmula que utilizei é =(SUMPRODUCT((B1:B5="M")*(E1:E5=1)))+(SUMPRODUCT(( B1:B5="M")*(E1:E5=0,4))*0,4)

    Acontece que tenho isto é apenas um exemplo e na realidade tenho imensos valores na coluna "E", mais critérios do que os descritos no exemplo e células cujo os valores são muito grandes, pelo que me dá que a fórmula é maior do que é permitido pelo excel. Alguém me consegue explicar outra forma de resolver esta questão?

    Obrigado
    sábado, 12 de fevereiro de 2011 00:12

Todas as Respostas

  • Camarada,

    o Excel tem um limite de texo para o tamanho das funções.

    O interessante seria voce começar a utilizar VBA. Com certeza conseguirá otimizar seus processos e não terá mais problemas deste tipo.

    Recomendo o material do Julio Battisti: www.juliobattisti.com.br


    Caio Vitullo
    sábado, 12 de fevereiro de 2011 13:16
  •   Quero contar (1) quantos M tenho que sejam engenheiros, mas cada um só vale o que está especificado na quarta coluna (2) ... ou seja terei 1,4.


    Acontece que tenho isto é apenas um exemplo e na realidade tenho imensos valores (3) na coluna "E", mais critérios do que os descritos no exemplo e células cujo os valores são muito grandes, pelo que me dá que a fórmula é maior do que é permitido pelo excel. Alguém me consegue explicar outra forma de resolver esta questão?

    1 - Você quer contar ou somar?

    2 - Quinta coluna, creio...

    3 - Não importa.

     

    Vamos lá:

    SOMAR:

    =SOMASES(E1:E1000;B1:B1000;"M";C1:C1000;"Engenheiro")

     

    CONTAR:

    =CONT.SES(B1:B1000;"M";C1:C1000;"Engenheiro")

     

    Abs,

    Aproveite e teste quantos critérios cada uma suporta... acho que são 127.

     

    quarta-feira, 16 de fevereiro de 2011 06:35