none
Publicação web site asp.net RRS feed

  • Pergunta

  • Boa tarde

    Sou iniciante e tenho breve noções de programação com asp.net, desenvolvi um site e hospedei em um servidor externo porém o mesmo me retorna o seguinte erro

    Server Error in '/infodds' Application.

    Runtime Error

    Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine. 

    Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".
    <!-- Web.Config Configuration File -->
    
    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>

    Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.

    <!-- Web.Config Configuration File --> <configuration> <system.web> <customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/> </system.web> </configuration>

    Alguém poderia me Auxiliar quanto ao que e necessário fazer?

    Agradeço desde Já

    obrigado

    quinta-feira, 28 de março de 2013 18:29

Respostas

  • depois de horas e horas

    consegui, por desencargo renomeei a pagina "default.aspx" para "index.aspx" ai funcionou........

    obrigado pelo apoio e paciência.

    sexta-feira, 29 de março de 2013 04:20

Todas as Respostas

  • Boa tarde,

    Vá no web.config da aplicação e sete o customErrors para Off, conforme informado para ver o erro que está ocorrendo.

    <configuration>
        <system.web>
            <customErrors mode="Off"/>
        </system.web>
    </configuration>

    A partir daí posso tentar ajudar.

    Abraços

    quinta-feira, 28 de março de 2013 20:10
  • ok

    vou modificar.

    obrigado por enquanto.

    quinta-feira, 28 de março de 2013 20:41
  • modifiquei e continua aparecendo o mesmo erro é este codigo abaixo pode verificar se modifiquei correto.

    <?xml version="1.0" encoding="utf-8"?>
    <!--
      For more information on how to configure your ASP.NET application, please visit
      http://go.microsoft.com/fwlink/?LinkId=169433
      -->
    <!-- Web.Config Configuration File -->



        <!-- For more information on Entity Framework configuration, visit http://go.microsoft.com/fwlink/?LinkID=237468 -->
        <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=5.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
      </configSections>
      <connectionStrings>
        <add name="DefaultConnection" providerName="System.Data.Mysqlclient" connectionString="Data Source=(LocalDb)\v11.0;Initial Catalog=aspnet-DDSINFO-20130314212633;Integrated Security=SSPI;AttachDBFilename=|DataDirectory|\aspnet-DDSINFO-20130314212633.mdf" />
      </connectionStrings>
      <system.web>
        <compilation targetFramework="4.5" />
        <httpRuntime targetFramework="4.5" />
     <customErrors mode="off" />
        <pages>
          <namespaces>
            <add namespace="System.Web.Optimization" />
          </namespaces>
          <controls>
            <add assembly="Microsoft.AspNet.Web.Optimization.WebForms" namespace="Microsoft.AspNet.Web.Optimization.WebForms" tagPrefix="webopt" />
          </controls>
        </pages>
        <authentication mode="Forms">
          <forms loginUrl="~/Account/Login.aspx" timeout="2880" />
        </authentication>
        <profile defaultProvider="DefaultProfileProvider">
          <providers>
            <add name="DefaultProfileProvider" type="System.Web.Providers.DefaultProfileProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" applicationName="/" />
          </providers>
        </profile>
        <membership defaultProvider="DefaultMembershipProvider">
          <providers>
            <add name="DefaultMembershipProvider" type="System.Web.Providers.DefaultMembershipProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="false" requiresUniqueEmail="false" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" applicationName="/" />
          </providers>
        </membership>
        <roleManager defaultProvider="DefaultRoleProvider">
          <providers>
            <add name="DefaultRoleProvider" type="System.Web.Providers.DefaultRoleProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" applicationName="/" />
          </providers>
        </roleManager>
        <sessionState mode="InProc" customProvider="DefaultSessionProvider">
          <providers>
            <add name="DefaultSessionProvider" type="System.Web.Providers.DefaultSessionStateProvider, System.Web.Providers, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" connectionStringName="DefaultConnection" />
          </providers>
        </sessionState>
      </system.web>
      <entityFramework>
        <defaultConnectionFactory type="System.Data.Entity.Infrastructure.LocalDbConnectionFactory, EntityFramework">
          <parameters>
            <parameter value="v11.0" />
          </parameters>
        </defaultConnectionFactory>
      </entityFramework>
    </configuration>

    quinta-feira, 28 de março de 2013 20:50
  • Não gerou mais nenhuma descrição?
    Para qual versão do .NET sua aplicação foi construída? Sabe se este servidor comporta a versão?
    quinta-feira, 28 de março de 2013 23:33
  • foi programado no vs2012!

    pode ter alguma coisa a ver com a base de dados?

    nao consegui identificar no site de hospedagem ate que versao comporta!

    sexta-feira, 29 de março de 2013 02:26
  • depois de horas e horas

    consegui, por desencargo renomeei a pagina "default.aspx" para "index.aspx" ai funcionou........

    obrigado pelo apoio e paciência.

    sexta-feira, 29 de março de 2013 04:20